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Set up BpComms for Best Health App

You can enable Best Health App integration for multiple practice locations. Each location is treated as a separate
entity and you must enable each one individually.

When you open the Best Health Settings setup utility from Bp Premier Configuration, the utility will retrieve
details for all the practice locations you have defined in Setup > Practice Details. You cannot add or remove loc-
ations from Best Health Settings setup, but you can update some practice details.

A user will need the Configuration and Best Health Settings permissions set to 'Add/Edit/Delete' to update Best
Health App settings.

Can I onboardmy practice to the Best Health App yet?

The Best Health App is available for general release. Your practice must upgrade to Jade SP1 and install the Octo-
ber 2019 data update before onboarding to use the Best Health App.

Internet Access Required
Your practice requires internet access to use Best Health App integration. The following URLs should be allowed
for BHA outbound/inbound traffic.

*ap-southeast-2.amazonaws.com (notice "*", so that all URLs ending with "ap-southeast-2.amazon-
aws.com" are whitelisted)
prod.bpbesthealthapi.net
cognito-idp.ap-southeast-2.amazonaws.com
cognito-identity.ap-southeast-2.amazonaws.com
s3-ap-southeast-2.amazonaws.com
*.bpbesthealthapi.net (notice "*", so that all URLs ending with "bpbesthealthapi.net " are whitelisted)

If applicable, whitelist the above URLs in your antivirus and firewalls to ensure that your server and all machines
that will use the Best Health App can access the above URLs.

Turn on Best Health App Functionality
Before using Best Health App, beta testers must make this functionality available in Bp Premier by running a
script.

1. Download the script to turn on Best Health App here. Clicking the link will download a .bpscript file to your
browser's default download directory (normally Users > Downloads or Quick Access > Downloads in Win-
dows).

If the link above does not work, you can also obtain the .bpscript file from the knowledge base link in the
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next step.

2. Follow the instructions on the support knowledge base to run the script.

Set user permission
A user will need the user permission Best Health Settings set to 'Add/Edit/Delete' to make changes in the Best
Health App Configuration window.

1. Log in to Bp Premier as an administrator-level user who can grant permissions.
2. From themain menu, select Setup > Users. Select the user to grant permissions to and click Edit.
3. Click Set Permissions.
4. Scroll down in the Permissions window and set Best Health Settings set to 'Add/Edit/Delete'.

5. Click Save and Save again to return to theUsers window.
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Onboard Your Bp Premier Location
You must onboard every location where you want to use the Best Health App functionality. Before onboarding
your location, check that the location details are correct in Bp Premier by navigating to Setup > Practice details
from themain screen. When you are sure the location details are correct, you can onboard on your location for
Best Health App:

1. Log in to Bp Premier as a user with access to Configuration.
2. Select Setup > Configuration from themain menu. Select the Bp Comms tab and click Configure Best Health

App.

3. Select a user and enter the user's password at the login screen and click Login. The Best Health Settings util-
ity will appear. In the example below, the location 'Gladstone' has already been defined in Setup > Practice
Details and the details for this location have been retrieved.
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4. Tick Enable Best Health App usage for this location. The tabs in the windowwill be enabled for editing.
5. You can update the practice details retrieved for this window. However, the details displayed here are for the

purposes of app onboarding only, and will not update the details stored in Setup > Practice Details. The details
that are entered into this screen will be visible to the users of the Best Health App who are enrolled at your loc-
ation.

6. You can set the location's Opening Hours, website if the practice has a website, and add a clinic logo to be dis-
played on the app.

7. If the practice location uses a third-party application to book appointments, enter the Appointment URL used
for third-party appointment booking.
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This link will be available from the appointment section of the patient's app. Clicking the link will open the
URL in themobile device's browser.

8. Click Save. Bp Premier will submit the request to Best Practice Software for processing. This may take a
minute.

Bluetooth beacon

Your Best Health App Welcome Pack contains one or more Bluetooth beacons that are configured to be used with
your location. The beacon allows patients to check in to their appointment within 30minutes of the appointment
start time if the app has detected the beacon is nearby. Once the appointment start time has elapsed, (60
seconds past the start time), check-in via the app is no longer available.

The beacon needs only to be plugged into a USB power source. The average range for the beacon is 20meters. If
your practice is large or has multiple reception areas, you may need more than one beacon. Best Practice Soft-
ware provides one free beacon in theWelcome Pack. Additional and replacement beacons are provided at an
extra cost.

The placement of the Best Health App beacon is significant, because walls, doors, and other obstructions can
impact the beacon’s signal quality. Materials like wood, synthetic materials, and glass possess low interference
potential. However, marble, bricks, concrete and metal have relatively high interference potential. Place the
beacon away from walls or any obstruction made ofmaterial with high-interference potential.

Bp Premier Best Health App Setup Guide Page 8



Preferred BpComms sendingmethod

The Preferred Practice contact method setting is used when sending Bp Comms via mail merge such as Clinical
Reminders or Follow up Inbox. In the Jade release, you can choose SMS or App as your preferred method of send-
ing Bp Comms. Contact methods become available for selection as a preferred contact method once they have been
enabled. If you do not have SMS or App configured then you cannot choose it as your preferred method.

1. Select Setup > Configuration from themain menu.
2. Select the Bp Comms tab.
3. In the Preferred Practice contact method section, select 'App' or 'SMS' from the Primary dropdown menu.

4. If you havemore than one Bp Comms method enabled, select it from the Secondary dropdown menu.
5. Click Save.

When you run a mail merge from a Bp Premier function, themessage will be sent by the default method selected
here, if the patient has been enabled or enrolled to use that method. If the patient is not setup to use either App or
SMS then the communication will be sent via Letter.

When you send a single message for a patient and they are enabled for both SMS and Best Health App messages,
then the default sending method is set using the Preferred Practice contact method setting. You can still select the
alternate contact method if desired.

This below table gives examples of how patient communication will be sent given various setups in Preferred
Practice contact method. In the below scenarios it is assumed that the patient has consented to receive all types of
communication via Bp Comms.

Preferred Practice Contact Method Patient Enrolled/Enabled Default method

Primary: App, Secondary: SMS App, SMS App

Primary: App, Secondary: SMS SMS SMS
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Preferred Practice Contact Method Patient Enrolled/Enabled Default method

Primary: SMS, Secondary: App App, SMS SMS

Primary: SMS, Secondary: App App App

Primary: SMS, Secondary: App None Letter
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BpComms Credit

A Bp Comms credit code contains a dollar amount that can be used for sending both Best Health App and SMS mes-
sages. Contact Best Practice Software Sales to obtain a Bp Comms credit code. You may have also received Bp
Comms credit as part of your Best Health App Welcome Pack.

HowMuch BpComms Credit Do I Have?
The balance of your Bp Comms credit is often displayed when you send a Bp Comms message. This information is
located at the bottom of the screen and displays howmany SMS or App messages you could send using your
remaining credit. You can also view your available credit by navigating to Setup > Configuration > Bp Comms.

Top up BpComms Credit
If a user has permission to access Configuration, he or she can top up the Bp Comms credit at any time.

1. Contact Best Practice Software Sales to obtain a Bp Comms credit code.
2. Go to Setup > Configuration and select the Bp Comms tab.
3. Under Bp Comms credits, enter the code you received into Enter code to top up credit and click Validate. Bp

Premier will update the Credits Remaining and Unused messages values.

Page 11 Bp Premier Best Health App Setup Guide



4. Click Validate. The Credits Remaining value should be increased by the top-up amount. It will also indicate
howmany SMS or Best Health App messages you can send with your remaining credits.

BpComms Credit Warnings andMessages
Configurable warning prompts and messages are available to ensure no interruptions occur to Bp Comms func-
tionality as a result of lack of credit.

BpCommsWarning Prompt

This prompt can be set up to remind you to contact Best Practice Software Sales to purchase additional credit. If
the available Bp Comms message credit falls below the configured limit a singlewarning prompt is displayed
whenever you enter a screen that can send a Bp Comms message. To configure the Bp Comms warning prompt:

1. Navigate to Setup > Configuration and select the Bp Comms tab.
2. Check theDisplay a warning prompt when remaining messages fall below checkbox.

3. Enter howmany messages you want remaining before you start receiving the warning prompt.
4. Select either App or SMS from the drop down list. Best Practice Software recommends selecting the

BpComms method you use themost.
5. Click Save.
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A prompt similar to belowwill display when your Bp Comms credit falls below the configured limit.

BpCommsWarningMessage

The Bp Comms warning message will send an internal Bp Premier message to the selected user when the available
message credit falls below the configured limit. This warning method is useful when automated Bp Comms are con-
figured as there is no window or screen to display a warning prompt. To configure the Bp Comms warning message:

1. Navigate to Setup > Configuration and select the Bp Comms tab.
2. Check the Send a message to a user when remaining messages fall below checkbox.

3. Enter howmany messages you want remaining before you start receiving the warning message. Best Practice
Software recommend that this value be set higher than the warning prompt, so that the nominated user has
time to order a new credit key before other users are warned about low credit.

4. Select either App or SMS from the drop down list. Best Practice Software recommends selecting the BpComms
method you use themost.

5. Select the user who you want to receive themessage in the Low credit warning message recipient drop down
list.

6. Click Save.

Amessage similar to belowwill be received when your Bp Comms credit falls below the configured limit.
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BpComms Consent

You must enrol a patient's mobile phone number and record their consent before they can receive Bp Comms mes-
sages from your practice. If you have previously obtained Bp Comms consent for SMS, the same consent can be
used for Best Health App enrolment.

Because Bp Comms allows you to send more than just appointment reminders, Best Practice Software recommend
that your practice review its consent process and determine any changes that may be required.

How does Bp Premier handle consent when I run amail merge?

When you run a bulk message sendout like clinical or appointment reminders, Bp Comms will default themessage
method for each patient based on:

what the patient has consented to receive (set in demographics)
the practice's preferred method (set in Configuration > Bp Comms).

After you select your schedule criteria, Bp Comms will show the breakdown of howmany patients will receivemes-
sages of each type (for example 5 letters, 1 SMS and 2 App messages).

Record patient consent and enrol in Bp Comms
1. Search for the patient using any of the patient search methods: File > Open Patient, View > Patient, or press

F2.
2. Click View details to open the Patient details screen.
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3. If the patient does not have aMobile Phone number recorded, you must record a valid number before you
can click Bp Comms Consent. Mobile numbers should start with a 0 and not include the country code prefix.

4. Click Bp Comms Consent on the right-hand side of the screen.
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5. The Bp Comms Consentwindowwill appear.

Set consent
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6. Under Consent Options, tick the Bp Comms message types that the patient consents to receive. Ticking a
message type will enable other buttons in this window.

7. If you need to store a signed consent form for the patient, click Open Bulk Document Import to scan and
import the signed consent form into Bp Premier.

NOTE A user will need permission to access the Bulk Document Import tool.

8. Click Link to signed consent. The Select signed consentwindowwill appear.

9. Tick the form you want to link to as themost recent and correct consent and click Select to return to the Bp
Comms Consentwindow.

Enrol in SMS

1. Under Consent Status, you can change theMobile Phone number.

The number must be in the Australian format of ‘0400 000 000’ (with or without spaces). The number must
not have a ‘+’ or ‘61’ prefix. Incorrectly formatted numbers will be rejected by themessage provider service
and will not be delivered.
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2. Click Enable to verify the patient's mobile number. The action required by the patient will depend on your Con-
sent/Enrolment settings in Setup > Configuration:

If Send patient SMS when enabling andMobile number verification is required are both unticked, the
patient receives no enrolment message, no patient action is required, and SMS enrolment is complete.
If Send patient SMS when enabling is ticked, the patient will receive an enrolment SMS message but no
further action is required. SMS enrolment is complete.
IfMobile number verification is required is ticked, the Verification Requiredwindowwill appear, sum-
marising the patient's Bp Comms consent. Click Send to send a validation code to the patient's mobile
phone, and enter the code into the box that appears. Bp Premier will validate the code and SMS enrol-
ment is complete.

NOTE Best Practice Software recommend mobile number verification to ensure that the intended
patient receives messages from your practice.

3. Click Save.
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Enrol in Best Health App

1. Open the Bp Comms Consent window via patient demographics > Bp Comms Consent

2. In the Best Health App drop-down list, select the location where the patient is enrolling. Click the Enrol but-
ton. The Enrol button becomes active when at least one Consent Option is chosen.

If the patient attends more than one of your locations and you want to enable them to use the Best Health
App at those locations, you must enrol them using the above procedure but change the location selected in
the Best Health App drop-down list.

Inside the Best Health App, the patient can filter messages, health summaries and other information by the
location it was received.

3. A confirmation message displaying the chosen consent options is shown. Ensure the correct options are
selected and click Send.
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4. The Best Health App status in the patient demographics window displays 'Pending' after the invitation is sent.

5. The patient will receive an invitation to use the app including a link to download it from the appropriate store.
Once downloaded they create their account, using the samemobile number as is recorded in Bp Premier.
There will be a new Invitation to enrol message in their App Inbox which needs to be accepted.

6. When the patient has accepted the invitation to enrol, the status will change to 'Enrolled'. The change of state
from 'Pending' to 'Enrolled' may take a fewminutes to appear after the patient has accepted the invitation.
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Set up BpMessaging Service

The Best PracticeMessaging Service is used to manage Bp Comms communications between Bp Premier and
external gateways. In the Jade release, its sole use is to used to facilitate communication between Bp Premier and
the Best Health App.

Most of the configuration for this service is automatically set up when you install the upgrade. However, you may
need to engage your practice's IT support to ensure that any network firewalls allow incoming and outgoing con-
nections to and from the Best PracticeMessaging Service. You can also nominate one or more users to receive an
internal Bp Premier message on login if the service is stopped.

Enable firewall access

The Best Practice Messaging Service is visible in theWindows Services screen.

If this service appears in the list, and you have enabled Bp Comms in Bp Premier Configuration, but messages are
not being forwarded, you may need to check that your network firewall is allowing the Best PracticeMessage Ser-
vice to communicate through TCP/IP ports.
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Warn a user when theMessaging Service stops

1. From themain screen of Bp Premier, select Setup > Configuration > Msg Queue tab.

2. Tick Send a message to these users....
3. Tick the users that you want to receive an internal Bp Premier message if themessage service cannot be con-

tacted.
4. Click Save to save your configuration.

Configure theMessage ServiceMachine Name

The Best PracticeMessaging Service is deployed by default on your Bp Premier database server machine. When the
Messaging Service starts for the first time, the configuration setting that stores the location of theMessaging Ser-
vice is updated to your server machine name; this allows client installs of Bp Premier knowwhere to send messages.
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If for some reason Bp Premier can not connect to your database server via machine name (for example, DNS
issues on your network), you can configure themessaging service to connect via IP address.

To configure theMessage ServiceMachine Name:

1. From themain screen of Bp Premier, select Setup > Configuration > Msg Queue tab.
2. From the top list, select a queue.
3. Click the Edit Machine Name button.

4. Enter the IP Address or machine name of your server.

NOTE If you are unsure how to obtain the IP Address of your server, contact your IT technician.

Bp Premier Best Health App Setup Guide Page 24



5. Click OK.
6. Repeat step 2 to 5 for each queue in the list.
7. Click Save.
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Fromwhere can I send Best Health Appmessages?

The following is a summary of Bp Premier functions where you can send SMS and/or Best Health App messages.

Bp Premier area Menu Description Consent Required

PatientWindow Bp Comms
> Send Patient
Message

Send a single
message to a patient.

As any text can be sent from this
area, it is up to the user to discern if
the communication they are sending
has been consented to by the
patient.

PatientWindow Bp Comms
> Send Health
Summary

Send a summary of
the patient's health
details stored in Bp
Premier.

Clinical Communications.

MIMS CMI File > Send
Leaflet

Send MIMS
Consumer Medicine
Information to the
patient.

Health Awareness

Patient Education File > Send
Leaflet

Send leaflets or
brochures stored in
Bp Premier to the
patient.

Health Awareness

Reminders Clinical
> Reminders.

Send clinical
reminders to a list of
patients.

Clinical Reminders

Search Utilities
> Search.

Send a message to a
list of patients
produced by
performing a
database search.

Health Awareness

Inbox View > Inbox. Send a single
message to a patient
regarding an item in
your Inbox.

Clinical Communications

Follow up inbox Clinical > Follow
up inbox.

Send a single
message to a patient
regarding an item in
your Follow Up
Inbox.

Clinical Communications

Appointment Book Utilities > Send
Appointment
Reminders

Send a list of
appointment
reminders.

Appointments
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Bp Premier area Menu Description Consent Required

Appointment Book Utilities > Send
Message

Send a single
message to a patient
regarding an
appointment.

Appointments
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