
Bp Premier Indigo SP1 Release Notes
These release notes describe all enhancements and modifications made to Bp Premier since version
Indigo (1.9.0.846).

Release Date  31 January 2019

Release version Indigo Service Pack 1 (1.9.1.863)

Notes last updated 25 March 2019

What is in this release? Indigo Service Pack 1 contains a number of new features, enhancements, and
bug fixes. Review the sections in this document for more information.

Which version can I
upgrade from?

You can upgrade to Bp Premier Indigo from version Summit (1.8.4.642) or
later.

Which data update do
I need?

You must install the November 2018 Data Update or newer before running the
Indigo upgrade. To check the current data update that you have installed, select
Help > About. You can download data updates from the Best Practice Software
website. Best Practice Software recommend installing the most recent Data
Update before running a Program Update.

Which database and
operating system
versions are supported?

System requirements have not changed from the Indigo release. Supported
database and operating systems versions are described in the Bp Premier
System Requirements, available here.

When should I upgrade? Best Practice Software recommend running the program upgrade outside of
business hours.

If you are upgrading from Bp Premier Summit edition, Best Practice Software
recommend planning your upgrade around an end of financial period event
such as end of month or after a disbursement period. This will allow you to
cleanly cut over to the new reporting system that was introduced in the Lava
edition (included in this release).

If you are upgrading from Bp Premier Lava or later, you can run the upgrade at
any time suitable outside of business hours.

Copyright Statement

This document is classified as commercial-in-confidence. Unauthorised distribution of this information may constitute a
breach of our Code of Conduct, and may infringe our intellectual property rights. This information is collected and managed
in accordance with our Privacy Policy, available on ourwebsite.
© Copyright 2019

https://bpsoftware.net/resources/bp-premier-downloads/
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How do I upgrade? Brief upgrade instructions are included in this document for upgrading from
DVD or downloaded file.

If you are upgrading from a version earlier than Indigo, review Where do I find
more information? in this document to familiarise yourself with new features
and changes that have been introduced since your current version.

What do I do after
upgrading?

This will depend on the version of Bp Premier you are upgrading from. You may
need to perform some configuration after your upgrade because of changes to
functionality.

Indigo SP1 Bp Comms introduces major enhancements in several workflows,
including pathology, clinical reminders, and patient consent to receive
communications. Best Practice Software strongly recommend you familiarise
yourself with the new features described in these release notes before you
upgrade.

In particular, review the article Understanding Bp Comms Consent so you fully
understand the implications of consent with the new Bp Comms message types.

Page 2 Bp Premier Indigo SP1 Release Notes

http://kb.bpsoftware.net/au/bppremier/indigo/Content/BpComms/UnderstandingBpCommsConsent.htm


Upgrade to Indigo Service Pack 1

You can upgrade to Bp Premier Indigo SP1 from versions:

Summit (1.8.4.642)
Lava (1.8.5.754)
Lava SP1 (1.8.6.801)
Lava SP3 (1.8.8.810)
Indigo (1.9.0.846).

Before you upgrade

1. Review the known issues to see if any issues may affect your practice, and any workarounds you
can apply. Known issues are available here.

2. Back up your existing database before upgrading and test that the backup restores successfully.
Store the backup file in a known location that is not the server. Information on how to back up
and restore your database is provided here.

3. If any laptops have a database downloaded for remote use, upload all remote data to the Bp
Premier server.

4. Log out all users of Bp Premier before you start the upgrade of the server or workstation.
5. Upgrade the Bp Premier server first and then ALL workstations at the same time. Workstations

that are not upgraded will be unable to access new features following the upgrade of the server.

Run the upgrade

Install the latest Data Update

You must have the November 2018 data update or later installed before you upgrade to Indigo SP1.
Check for themost recent data update available from the Best Practice Software web site before you
run the program update.

1. Open the Best Practice Software websitewww.bpsoftware.net in a browser.
2. Select Resources > Bp Premier Downloads. Scroll down to theData Updates section.
3. Click theData Update: Data Update - Comprehensive update for themost recent data update.

The update rowwill expand.
4. Click Download to download the file to your browser’s download directory, or right-click and

select Save target as... or Save link as... to download to a location of your choice.
5. Copy the update file BPS_Data_xxxxxx_comp.exeto the Bp Premier server computer. The file-

namewill depend on the date of the Data Update.
6. Double-click the file to run the Data Update.

Install the Program Update

When Bp Premier Indigo is released, the upgrade file will bemade available from the Best Practice Soft-
ware websitewww.bpsoftware.net from the Resources > Bp Premier Downloads page. You can also
upgrade from the Bp Premier Indigo Installation DVD, if your practice has received a DVD mailout.
Insert the DVD to start the installation.

1. Open the Best Practice Software websitewww.bpsoftware.net in a browser.
2. Select Resources > Bp Premier Downloads.
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3. Under the Program Updates heading, click Software: Bp Premier 1.9.1.863 to expand.
4. To view documentation associated with upgrading to the new release, click the hyperlinks in the

description.
5. Click Download to download the file to your default download directory, or right-click and select

Save target as... or Save link as... to download to a location of your choice.
6. Copy the upgrade file BP_1.9.1.863.exe to the Bp Premier server computer.
7. Double-click the file to start the upgrade.
8. Copy and run the file on each workstation to upgrade all workstations.

After you upgrade

Review the new features introduced in Bp Premier in all releases since you last upgraded for any
changes required to workflows at your practice. New features are summarised in the table below.
More information is available from the IndigoWhat's New? page here.
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Where do I findmore information?

I am upgrading from... I need to know about...

Summit (1.8.4.642) The Lava release introduced major changes to reporting and location
functionality:

Multiple practice locations
New management reports
Grant access to a new report
Adjustments and deposits
Using deposits

Read the Bp Premier Lava Release Notes.

Lava (1.8.5.754) The Lava Service Pack 1 release introduced online claiming support for
practices with multiple Minor IDs registered with Medicare:

Set up online claiming for multiple Minor IDs

Read the Bp Premier Lava SP1 Release Notes.

Lava SP1 (1.8.6.801) The Lava Service Pack 3 release introduced major changes to cervical
screening (formerly pap smear) terminology and requests:

Cervical screening

Read the Bp Premier Lava SP3 Release Notes or the Quick Reference Guide.

Lava SP3 (1.8.8.810) The Indigo release introduced the following new features:

Tyro Bulk Billing
Subpoena tool for patient record export
Clinically significant reminders

Read the Bp Premier Indigo Release Notes or a Quick Reference Guide:
Subpoena Tool, Bulk Bill Easyclaim, Reminders.

Indigo (1.9.0.846) New features in Indigo Service Pack 1 are described in these release notes.

The Bp Premier Indigo Knowledge Base also provides the following guidance:

Bp Premier Indigo System Requirements
Bp Premier Known Issues
Bp Premier Installation Guide (for new installations)
General Bp Premier usage information.
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New Features

The following new features have been included in the Indigo SP1 release. For a complete list of all
enhancements made to Bp Premier in this release, see the tables of enhancements in this document.

BpComms

Bp Comms is an exciting new feature set of Bp Premier that expands practice-patient communications
and provides a comprehensive audit trail of contact attempts throughout clinical workflows:

You can now send clinical reminders by SMS.
From most clinical and management functions, you can now record Contact Notes to capture all
details about your practice's communications with patients, whether by phone, letter, or SMS.
Mail merge to SMS is now available from more functions, such as the database search utility.
You no longer have to run a database search and switch to the Reminders function. You can run a
database query and run a merge from the search results.

The sections below explain howBp Comms affects several areas of Bp Premier, and the new features
you need to be aware of when you upgrade to Indigo Service Pack 1.

Contact notes

A contact note represents any attempt to contact a patient by the practice, by phone, letter, or any
electronic method consented to by the patient. To avoid breaking out of a workflow, staff can raise a
contact note from multiple functions in Bp Premier where a communication might be necessary, includ-
ing the appointment book, Follow up Reminders, Follow up Inbox, patient demographics, and sec-
tions of the patient record.

A note records the details of the patient or person contacted (if a next of kin or carer responds, for
example), the contact reason, communication method, the number of contact attempts, and the suc-
cess status.

Practice and patient consent

Bp Comms allows you to send more than just appointment and clinical reminders to patients. In the
patient demographics, you record which types of communication a patient consents to receive:

Appointment reminders
Clinical reminders
Other clinical communications (such as returned results or other clinical messages)
Health Awareness (patient education and practice campaign materials).

Patients must now enrol to receive communications by SMS message. You can set up Bp Premier to
require mobile number validation before Bp Premier includes the patient in SMS communications. You
can also now import a practice consent form, signed by the patient, into the patient's demographics.

When sending out bulk SMS reminders, Bp Premier will automatically choose themost suitable com-
munication method based on:

the electronic communication methods your practice has enabled for use in Setup
> Configuration > Bp Comms
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the contact types that a patient has consented to receive
the contact methods that a patient is able to receive.

For example, say that you are sending out clinical reminders to 20 patients, 18 of those patients have
enrolled in SMS, and SMS is your practice's preferred primary contact method. When you review the
reminders from the Reminders window, Bp Premier will automatically default the 18 enrolled patients
to receive a reminder by SMS, and run a mail merge letter for the remaining 2 patients. You can modify
the defaults before sending.

Patient messaging

You can now also send an SMS message directly to a single patient from the patient record, Provider
Inbox, and Follow up Inbox.

Clinical Reminders

The clinical reminder workflow has been redesigned in Indigo SP1 to take advantage of SMS.

When you produce a list of patients for a reminder mailout from the Reminders window, you are no
longer limited to a mail merge letter. Bp Premier will automatically default the contact method to use
for all patients in the reminder list based on practice preference and patient consent. If a patient has
more than one clinical reminder to receive, you can combine reminders into a single message.

You can still send reminders to letter, label, or file as in previous versions. Sending a reminder will auto-
matically add a contact note of reason 'Reminder' to the patient's demographics.

The Previously Sent Reminders window (Reminders > View > Sent Reminders) has been improved to
give practices more options in managing sent reminders: 

This window has been renamed to Follow up Reminders
More actions have been added to resolve a followup: View contact notes, book an appointment,
mark as no longer required, or mark as performed.
From the right-click context menu, you can also mark as 'Declined' or mark as 'No response'.
The Contact Attempts column indicates the number of contact notes associated with a reminder.

The Reason column in both the Reminders and Follow up Reminders windows indicates if a reminder
is clinically significant.

Appointment Reminders

The SMS Reminderswindow (Appointment Book > Utilities > Send Reminders) has been improved
under BP Comms: 

This window has been renamed to Appointment reminders.
You can now indicate which practice locations to include when selecting appointments for the
reminder sendout.
You can send SMS messages of length greater than 160 characters. If a message has exceeded the
character limit for a single message, Bp Premier will warn the user that themessagemay cost mul-
tiple credits.

You can also now record an appointment contact note from the right-click context menu in the
appointment book.
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Instead of only 'Yes' or 'No', in Setup > Configuration > Appt Reminders, you can now configure the
patient response text to appointment reminder messages that will update the appointment book. For
example, you could set Bp Premier to accept any of 'Y', 'Yes', or 'Ok'.

Permissions

The user permission 'Send SMS Reminders' has been renamed to 'Send Bp Comms Messages'. This
user permission now governs all electronic communication methods sent from anywhere in Bp
Premier, including patient education material. To send an electronic message, the user will require this
permission and permission to access that function of the software set to at least 'View'.

Depending on where they are recorded from, contact notes are linked to an area of Bp Premier, such
as appointments or correspondence in. Permissions have been updated in Indigo SP1 to also govern
access to linked contact notes.

For example, to view contact notes created from Correspondence in in the patient record, the user
must have the 'Correspondence In' permission set to 'View only' or greater. To delete a contact note
related to an investigation result, the user must have the permission 'Investigation reports' set to 'Add
/ Edit / Delete'.

Windows Services

A newWindows service Best Practice Messaging Servicewill be installed when you upgrade to Indigo
SP1. TheMessaging servicemanages incoming and outgoing Bp Comms communications. The service
runs on both the server and clients. Message queue activity is written to C:\ProgramData\Best
Practice\Log\MessageQueue.log.

The Setup > Configuration > Msg Queue tab allows Bp Premier administrators to check the status of
theMessaging service, and nominate one or more administrator-level users to receive an internal
warning if the service fails.

TheMessaging service will install and start up without user intervention, and users should never need
to reconfigure the service. However, if your practice network uses firewalls, your system administrator
may need to adjust your firewall settings on Bp Premier machines to allow incoming and outgoing Bp
Comms.

HealthShare Directory

Indigo SP1 offers HealthShare's online directory of health providers from the word processor.

When you look up a referral or contact for a document, you can search an online directory for pro-
viders from theHealthShare tab of the Select addresseewindow. Search by name, speciality, and post-
code to retrieve a list ofmatching specialists and practices.

The default address book to use for a provider is set in Setup > Preferences > Letters. If a provider has
not set this preference, he or she will be prompted to select a default address book the first time the
word processor is opened.

Healthlink Directory

This release of Bp Premier includes access to Healthlink 's online directory of health service providers.
When editing documents with the Bp Premier word processor, you can look up and insert details for a
health service provider from the online directory, as well as contacts stored in Bp Premier's local con-
tacts list. You can import and synchronise your local contacts list with the online directory.
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Prescribing

From theNew Rx window, a Bp Premier user can now select a provider to prescribe on behalf of.

A new user permission Prescribe on behalf of enables this function. If this permission has been set to
'Allow access', the user will see a Prescriber dropdown at the bottom of theNew Rx window. The Pre-
scriber dropdown will only list users who have a Prescriber number recorded and is mandatory as fol-
lows:

If the logged-in user has a prescriber number, the Prescriber dropdown will default to the current
user, but any other user with a prescriber number can be selected.
If the logged-in user does not have a prescriber number, the Prescriber dropdown will be blank,
and another usermust be selected from this dropdown before the NewRxwizard can continue.

SafeScript (Victoria only)

Indigo SP1 includes support for the Victorian government's SafeScript initiative to monitor dis-
pensation of high-risk medication. If a prescriber has the Enable SafeScript option ticked in Setup
> Preferences > Prescribing, when monitored drugs are prescribed, Bp Premier will connect to the
SafeScript database and pass through any alerts that apply to the drug and patient.

Licensing

Bp Premier has introduced improvements to better communicate to users when provider numbers or
hours booked have exceeded the limitations of your Bp Premier licence:

Bp Premier will display a warning when a PracticeManager or Principal Doctor logs in and the
number of Allied Health Professional users exceeds the number permitted by your licence to use
the billing module.
Bp Premier will display a warning when a user attempts to book more than 25 hours of appoint-
ments in a single week for a part-time provider, or a part-time provider opens an appointment
from the waiting room, and the provider's booking history for the previous four weeks indicates
that the part-time hours limit has been reached.

Drug database backup and restore

The BPS Backup utility has been improved to include backing up and restoring the drug database. This
will assist sites in restoring drug databases that have become corrupted.

A new option Setup > Configuration > Database > Backup drug database at the end of a data update,
if ticked, will back up the drug database automatically after running a monthly data update, and store
the backup file to the default Bp Premier backup file location, or an alternate location specified by the
administrator.

On a Bp Premier server, you can run BPS Backup to manually back up or restore the drug database.

On a client, you can restore the drug database only, including restoring the drug database on a
remote workstation disconnected from the Bp Premier server.
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Clinical Enhancements

Bp Function Release Notes Key

Bp Comms As part of the new Bp Comms function, providers can now record
contact notes from the following sections of the patient
record: Investigations, Correspondence In, Correspondence out, and
Clinical images.

If you move a document to another section in the patient record,
associated contact notes are also moved.

BP-39

Bp Comms (Clinical
Reminders)

The Reminders and Follow up reminderswindows have been
improved.

See Clinical Reminders on page 7 for more information.

BP-44

Bp Comms
(Contact notes)

An extra column Note has been added to the Investigation Reports,
Correspondence In, Correspondence Out, Clinical Images, and EPC
sections of the patient record. 'Y' in this column indicates a contact note
is attached.

BP-918

Bp Comms
(Followup Inbox)

You can now send a message using one of the patient's consented
electronic methods from the Follow Up Inbox.

BP-42

Bp Comms (Inbox) You can now send a message using one of the patient's consented
electronic methods from the Inbox.

BP-41

Graphing When importing a patient with observation data that may not exist in Bp
Premier, the observation values can now be atomised and graphed.

BP-197

HealthShare
Referrals Directory

Indigo SP1 provides access to HealthShare's online directory from the
word processor.

See HealthShare Directory on page 8 for more information.

BP-113

Imaging 'Breast' and 'Prostate' have been added to the list of available selections
for both genders when creating an Imaging request of type MRI.

BP-752

Immunisations National Immunisation Program (Childhood) Schedule changes from 1
July 2018 have been applied to the Childhood Immunisations section of
the patient record.

BP-827

MIMS CMI You can now email links to MIMS Consumer Medicines Information
leaflets to a patient (Patient record > View > MIMS Consumer
Medicines Information). The link will download the document to the
patient's device.

BP-49

My Health Record My Health Record menu labels have been updated. BP-866

Prescribing The Current Rx section of the patient record now includes Select all
and Select red buttons for selecting all current Rx and selecting all 'fully
used' Rx respectively.

BP-1032
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Bp Function Release Notes Key

Prescribing The Approval No. in the New Rx window is correctly populated with
'Z' if the Quantity or Repeats values are increased for a streamlined
drug.

BP-591

Prescribing A space now appears in Today's Notes between trade and generic
names if both are selected.

BP-588

Prescribing A user can now prescribe on behalf of another prescriber.

See Prescribing on page 9 for more information.

BP-198

Prescribing
(Victoria only)

The option Enable SafeScript has been added to Setup > Preferences
> Prescribing for providers in Victoria who wish to enable this
prescription service. 

BP-896

Prescribing
(Victoria only)

If a practice has both eRx and MediSecure configured for use with Bp
Premier, a provider is prompted at login to select which electronic
prescription service they wish to use for electronic Rx.

If eRx is already installed and a practice begins configuring Bp Premier
MediSecure for use with Bp Premier (or vice versa), Bp Premier will
prompt the user to confirm that the original installed electronic
prescription service will be disabled.

BP-893

Prescribing
(Victoria only)

If SafeScript is enabled for a provider, when the provider prescribes a
monitored drug, or changes the prescribed quantity, Bp Premier will
contact SafeScript to check the monitored status for the practice's state
and pop up any warnings generated from SafeScript. If SafeScript
cannot be accessed online, Bp Premier will alert the user.

Today's Notes
(backdating)

The Visit date field of the Today's notes section of the patient record
can no longer be set to a date earlier than one month prior to the
current date. This prevents excessive backdating of new notes.

BP-693

Today's Notes
(printing)

Visit notes that are included in a document and printed from the word
processor now include a Recorded on date to indicate when the notes
were recorded in Bp Premier.

BP-694

Travel medicine When immunisations are printed or saved from the Travel Medicine
window, the note added to Today's Notes now includes the countries
checked.

BP-903
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Management Enhancements

Bp Function Release Notes Key

Appointment
Reminders

A new field <DayofWeek> has been added to the list of fields for
Appointment Reminder templates in Setup > Configuration
> Templates. This field will display the day of week of the appointment
(Monday, Tuesday, etc.).

BP-46

Appointment
Reminders

Improvements have been made to the SMS Reminderswindow.

See Appointment Reminders on page 7 for more information.

BP-48

Bp Comms You can now configure the keywords that your practice will accept
from patient SMS reminder replies to indicate accepting or declining
appointment attendance. For example, you could configure Bp Premier
to accept 'Yes', 'Y', and 'OK' as confirmation of attendance.

BP-38

Bp Comms A new Bp Premier Windows service called Best Practice Messaging
Service has been introduced in Indigo Service Pack 1 to manage all
incoming and outgoing practice electronic communications.

See Windows Services on page 8 for more information.

BP-34

Bp Comms Added Resend message functionality to Contact notes list window. BP-11

Bp Comms Consent to receive different types of communications from your
practice has been enhanced to match the new Bp Comms feature.

See Practice and patient consent on page 6 for more information.

BP-31

Bp Comms Message statuses for the different methods of communicating from Bp
Premier (SMS, Email, Letter, Phone) have been standardised.

BP-30

Bp Comms Templates for all electronic communication types are managed from a
central location in Setup > Configuration > Templates. Types include
common practice messages such as clinical and appointment
reminders, result notifications, and bulk messages from a database
search.

BP-32

Bp Comms
(Appointment
Replies)

When viewing the details for a contact note that is an SMS appointment
reminder, you can view all of the replies sent by the patient.

BP-605

Bp Comms
(Contact Notes)

A new window View > Contact Notes displays contact notes for all
patients in Bp Premier.

Contact Notes are viewable from many functions of Indigo Service Pack
1, but only show contact notes for the patient and context. The Contact
Noteswindow from the main menu shows all contact notes that have
been recorded. Use the filters at the top of this screen to restrict the
contact notes that are displayed.

BP-45
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Bp Function Release Notes Key

Bp Comms
(Contact Notes)

Contact notes have been added to allow practices to record a visible
history of patient contact.

A contact note represents any attempt to contact a patient by the
practice, by phone, letter, or any Bp Comms electronic method
consented to by the patient. Contact notes can be recorded from
multiple functions in Bp Premier, such as Follow up Reminder, Follow
up Inbox, patient demographic, and the patient record. A note records
the details of the patient or person contacted (if a next of kin is
contacted, for example), the communication method, the number of
contact attempts, and the message status.

View > Contact Notes shows the history of all recorded contact notes.
Otherwise, contact note history is limited to the patient in context.

BP-200

Bp Comms
(Contact Notes)

The Contact Reason 'General' on the Contact note window indicates
that the contact note is not related to a specific correspondence or
reminder. Notes raised from the Contact noteswindow will default to
this contact reason.

BP-1015

Bp Comms
(Database mail
merge)

Prior to Indigo SP1, staff had to run a database search to extract a list of
patients, and then send bulk reminders from the Reminderswindow.

You can now send reminders using patients' preferred communication
method directly from the Database Search window. Bp Premier will
automatically detect the preferred method for each patient in the
result set, with an option to create a mail merge letter for those
patients without a preferred electronic method.

BP-43

Bp Comms
(Permissions)

Contact notes are available from many Bp Premier functions in Indigo
SP1 and can be linked to a contact reason, such as a reminder, result, or
appointment.

Permissions have been updated to control access to contact notes
based on contact reason. For example, to view contact notes from
Correspondence in in the patient record, the user must have the
Correspondence In permission set to 'View only' or greater. To edit
contact notes related to a patient invoice, the user must have the
permission Invoice set to 'Add / Edit / Delete'.

BP-770

Bp Comms
(Permissions)

The user permission 'Send SMS Reminders' has been renamed to 'Send
Bp CommsMessages'. This user permission now applies to all Bp
Comms electronic communication methods sent from any window in
Bp Premier, including patient education material.

BP-691

Bp Comms
(Templates)

When a new template is created for all message Types except
'Appointment', 'MIMS Leaflet', and 'Patient Education Material', Bp
Premier appends the text 'Do not reply' to the template text. This text
can be edited or deleted.

BP-769

Bp Comms
(Templates)

A standard set of BP Comms templates for all contact types are
provided with the Indigo SP1 release.

BP-773
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Bp Function Release Notes Key

Printed invoices
and receipts

For practices that tick the Print Medicare No and DoB on invoices and
receipts option in Configuration > Billing, the patient's Medicare
number and DOB are now printed in a different area on the A4 printout
so that these details will not appear in an envelope's transparent
window.

BP-574

SMS messages Indigo SP1 now allows you to send SMS messages to patients from the
following functions: Inbox, Follow up Inbox, Clinical Record, and Utilities
Search. Bp Service has been updated to check for Delivery and Reply
updates from the new functions.

A refresh option is available to check for the latest replies from the
Follow Up Inbox, Contact Notes list, and Appointment Book.

BP-12
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Licensing and Installation Enhancements

Bp Function Release Notes Key

Drug Updates
(Backup and
Restore)

The BP Backup utility has been improved to include backing up and
restoring the drug database.

See Drug database backup and restore on page 9 for more
information.

BP-160

EULA The Best Practice Software EULA for Bp Premier has been updated in
Indigo SP1.

BP-859

Installation The installation and upgrade wizards have been improved to reduce
potential conflicts arising from unsupported operating systems or
databases:

The installation wizard will default selection to the minimum version
of SQL Server supported by the operating system.
If a version of SQL Server is selected during installation that is not
supported by the computer's version of Windows, the installation
wizard will warn that the selected SQL Server version cannot be
installed. The user must select a supported version to proceed with
the installation.
Attempts to install or upgrade Bp Premier Indigo or later on a ver-
sion of Windows no longer supported will result in a warning mes-
sage. The installation will be halted.

BP-117

Installation The Database Selection panel of the installation wizard now shows the
version and platform of the operating system on which you are
installing.

BP-118

Licensing Bp Premier has introduced improvements to better communicate to
users when provider numbers or hours booked have exceeded the
limitations of your Bp Premier licence.

See Licensing on page 9 for more information.

BP-1

Virtual Memory
Logging

Virtual memory and runtime details are written to BPSError.log and
displayed in Help > About > System Info.

BP-636
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Reporting Enhancements

Bp Function Release Notes Key

Printing reports A new option Page break between each top level group has been
added to the Configuration tab of the Choose the Report Parameters
window. This option will insert page breaks at the highest group level
when printing. For example, payments, services, and transactions
reports can group by provider and print each provider to separate
pages.

Page separation is preserved when exporting to Word, Excel, or PDF.

BP-729
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Clinical Bugs Fixed

Bp Function Release Notes Key

Observations Some slowness opening patient records with observation data has been
resolved.

BP-1026

Today's Notes Bold, italics, and underline buttons and shortcut keys now apply the
style regardless of the styles already applied to the selected text.

BP-1002

Care Plans A fatal error occurred closing Bp Premier when a Care Plan preview
window was still open or when printing a Care Plan. This has been
resolved.

BP-962

Prescribing with
MediSecure

Scripts using MediSecure were taking longer to print. This has been
resolved.

The first script of the day at a practice may still take longer to print.

BP-906

Investigation
reports

Opening a HL7 report with hyperlinked URLs resulted in 'Text Control'
errors. This has been resolved.

BP-824

Diabetes Cycle of
Care

You can now use the '<' and '>' characters when entering values for a
Diabetes Cycle of Care record.

BP-794

eRx Some sites have experienced errors when printing scripts using eRx.
This has been resolved.

BP-779

Linked
immunisations

For practices that link immunisations to third-party software, provider
name, provider number, and sequence number were not being
exported to the Imm.OUT file. The 6-month Rotavirus vaccination also
remained checked in the patient record after the vaccination is
deleted.

These issues have been resolved.

BP-772

Past Visits Past visits can no longer be viewed and amended by users with Clinical
notes permission set to 'No access'.

BP-764

HealthShare fact
sheets

When a fact sheet is opened in the default browser, a button now exists
in the web page to generate text about the printed fact sheet that can
be pasted into Today's Notes.

When a fact sheet is emailed, a note in the format of 'Healthshare fact
sheet <fact sheet name> emailed to <patient email address>' is now
written to Today's notes. The provider must have Generate progress
notes as actions are taken ticked in Setup > Preferences > General.

BP-706

ADF Post Discharge
Summary

ADF Post Discharge Summaries that have not been previewed or
finalised are now included in patient record exports, including the
subpoena tool.

BP-703
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Bp Function Release Notes Key

Prescribing If a user clicked Delete while printing a script, Bp Premier could
generate an error. The Delete button is now disabled until printing is
saved or cancelled.

BP-56

Prescribing
(MediSecure)

Removed * from allowable characters when generating aMediSecure
barcode printed on e-Scripts.

BP-58

Incoming reports Allocating a result to a doctor now correctly records the Updated and
Updated By values.

BP-61

Cervical Screening Reusing a previous sent Cervical Screening Test request was not
populating the Cervical Screening details correctly. Due to the long
interval between normal results of a CST request, reusing a sent
Cervical Screening Test request now only carries forward the Fasting,
Hysterectomy, Radiotherapy, and Post Menopausal details.

BP-687

Imaging requests New lines in text entered into the Details to be printed on form field
under Clinical Details in the request were not being wrapped correctly
in the printed form, leaving some text truncated. This has been fixed.

BP-158
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Management Bugs Fixed

Bp Function Release Notes Key

Word Processor Insert an autofill in the Word Processor now leaves the cursor in the
correct position on the same line.

BP-797

Medicare forms Some practices encountered slowness when printing the DB4 or other
Medicare forms. Printing these forms is now faster.

BP-62

Online claims Some incentive items were causing the wrong item numbers to be sent
to Medicare in bulk bill claims. This has been resolved.

BP-74

Account
adjustments

Apply multiple operations rule option setting is correctly retained
when adjusting an account.

BP-582

Account
adjustments

Service details text is no longer incorrectly added to the description
when accounts are adjusted.

BP-581

Accounts When printing an account where the Provider is set to 'Practice', the
practice's ABN is now correctly used rather than the logged-in user's
ABN .

BP-77

AIR submissions When transmitting to AIR, if a patient has incomplete or incorrect
address details, the error raised now includes the patient name.

BP-79

Online claiming If Medicare or DVA pays a higher amount than that claimed, adjustment
records are inserted to change the Service amount to match what was
paid. However, the payment record was being allocated against the
original service record.

Payment records are now correctly allocated against the active,
adjusted service record.

BP-91

Certificate
Manager

The Bp Premier certificate manager now imports certificates from the
correct location when Bp Premier is started or when Import
Certificates is run from the Configuration window.

BP-96

Online Claiming From the Online claim batch window, when adjusting a service to
resolve an online claim exception, the adjustment was applied to other
services in the list, even for paid services that should only allow Accept
fee of. Adjustments to services from this window are now only applied
to the selected service.

BP-98

Accounts When adjusting an account from the Patient or Account Billing History
windows, you can now set the Time of Service as if creating the
account for the first time. This allows you to update the time of service
if you change the items in an account.

BP-131

Bp Premier Indigo SP1 Release Notes Page 19



General Bugs Fixed

Bp Function Release Notes Key

Payments Some text was present in the lower left corner of the Payments
window when viewing some payments. This text no longer appears.

BP-184
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Known Issues

Issue Workaround Fixed in Key

When enrolling a patient's
phone number, Bp Premier
checks to see if any other
patients have the same mobile
phone number recorded.

However, this check will not
report a duplicate number if
the same phone number has
been recorded with spaces.

For example, if a number has
been recorded as
'0417703579' for one patient
and '0417 703 579' for
another, Bp Premier will not
detect the duplicate.

Ensure that your staff record phone numbers
with consistent formatting when entering
patient details.

Not yet
resolved.

BP-1672
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Issue Workaround Fixed in Key

During an upgrade to Indigo
Service Pack 1, Update
Databases may fail due to an
error if the Windows user
running the upgrade does not
have local permission to
access the directory
C:\ProgramData\Best
Practice\Log.

This can affect the transfer of
your SMS credit balance.

You will need to manually rerun Update
Databases after the upgrade. This can take up to
two or more hours, depending on the size of
your database, and is best run after hours.

Until you have performed the resolution steps
below, SMS usage at your practice will be
limited as follows:

The use of SMS within the practice and all
locations will cease to work, and all SMS
schedules configured to run will not pro-
ceed.
The practice would need to fail back to
manually calling all patients with appoint-
ments for subsequent days to confirm
patient attendance, and reschedule those
patients waiting for an available appoint-
ment.
The practice will not have the ability to send
out ad hoc SMS notifications, such as a doc-
tor running late.

Perform the following steps after normal
business hours: 

1. Back up the Bp Premier database.
2. Double-click the file C:\Program Files\Best

Practice Software\BPS\Update Data-
base.exe.

3. Log back in to Bp Premier and check the
vale of your SMS credit . The value from
before the upgrade should be transferred.

If you have further concerns if your site
experienced this error, and you have rerun
Update Databases after hours, export BP log
files using the instructions here and send the
log zip file to Bp Premier Support.

This issue is
caused by
local
permissions.

BP-1577

Users are omitted from a
Shared Health Summary
report if their User ID does not
exist in the Invoices table (that
is, the user has never been
associated with an invoice).

Applies to practices that are
running version Indigo and
have run the February 2019
Data Update.

Create and cancel and invoice for any omitted
users so that they are recorded in the Invoices
table.

Install the March 2019 Data Update to install
the corrected version of this report.

Resolved in
March 2019
Data Update.

BP-1584
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Issue Workaround Fixed in Key

Adjusting an invoice after a
failed Bulk Bill Easyclaim
transaction does not update
the services on the invoice
correctly. This issue most
commonly occurs when the
Tyro transaction fails because
the patient’s Medicare card
details have not been updated.

This issue may also be
experienced for sites running
Indigo and Indigo Revision 1.

If you experience this issue, call Bp Premier
Support for assistance in correcting Bulk Bill
Easyclaims that have required invoice
adjustments.

Not yet
resolved.

BP-1487

The appointment book will not
automatically refresh and must
be manually opened and
closed to refresh.

This issue occurs if the
operating system time on a Bp
Premier client differs by more
than a few seconds from the
time on the Bp Premier
server.

Resynchronise the time on the client machine
to be exactly the same as the time on the Bp
Premier server.

Close and re-open the appointment book to
refresh.

Not yet
resolved.

BP-1585

When using a workstation with
a database that has been
remotely downloaded, an
'Invalid Object Name' error
occurs when printing
prescriptions. The prescription
can be printed, but SafeScript
checks will not occur.

No known workaround. Not yet
resolved.

BP-1563
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Issue Workaround Fixed in Key

If a non-RTF format result file
has been saved to a patient file
under Investigations, and a
workstation downloads the
database remotely to operate
in remote mode, the result file
will no longer be viewable

If while in remote database
mode the result file is moved
to Correspondence In, and the
remote database session is
synchronised back to the
server, the result file is
replaced by the blank file and
is no longer readable.

This also can also occur for
sites running Indigo Revision 1.

If a blank result appears in Investigations while
in Remote Database mode, do not move this
file to Correspondence IN.

Not yet
resolved.

BP-1593

Duplicate payment records
can occur if two users run
Check for Payment at same
time.

When running the Services -
By Account Type (Grouped by
item) report and similar
reports, a 'Subquery returned
more than 1 value' error may
be returned. This error may be
caused by performing multiple
service adjustments within
Online claiming.

Please contact Best Practice Software Support
for advice if you experience this issue.

Not yet
resolved.

BP-1294

Marking an item in the
Correspondence In section of
the patient record as 'Given'
can cause slowness if the
patient has a large number of
documents in Correspondence
In.

This issue also occurs for
version Indigo.

No known workaround. Not yet
resolved

BP-1261

The HealthLink online
directory does not refresh
existing search results when a
name is cleared from the
Name search field.

Clear the postcode value and re-enter it to
regenerate search results.

Not yet
resolved

BP-1118

Page 24 Bp Premier Indigo SP1 Release Notes



Issue Workaround Fixed in Key

A 'numeric overflow' error
may appear that is generated
by Bp Premier's system
logging.

If this error occurs more than once, restart Bp
Premier on the computer that experienced the
error.

Not yet
resolved

BP-1200

The Backup database button
on the BPS Backup utility may
be disabled when running a
manual backup.

Set the registry key HKEY_LOCAL_
MACHINE\SOFTWARE\WOW6432Node\Best
Practice Software\Best Practice\Database
> Server to 'local' and reattempt the manual
backup. Your IT support can assist with updating
the registry.

You may need to change the registry value back
to its original setting.

Not yet
resolved

BP-1336

The default location for a
manual backup (normally the
last manual backup location) is
reset if an automatic
scheduled backup is set up or
run.

Manually change the default location to the
desired location when performing a manual
backup.

Not yet
resolved

BP-1341

When you right-click a batch
and select Get processing
report, the Online claim
processing report does not list
the surname of the patient for
DVA claims.

Save the report, double-click the batch, and
review all of the rejections with the patients'
first name and surname. If a practice is only
interested in viewing the data, you can print the
report or go to View > Processing reports.

Not yet
resolved

BP-1116

When adding batches to the
Banking window, some sites
may experience long waits to
load available batches.

Contact Best Practice Software Support for a
script to resolve the issue.

Not yet
resolved.

BP-1478

When creating a Bp Comms
SMS template with
autopopulate fields that do not
apply to the selected template
type, an unrecoverable error
can occur.

Do not manually insert or cut and paste fields
between different SMS template types. Only
ever insert autopopulate fields by selecting
from the list of available fields in the Edit Bp
Comms Template window.

Not yet
resolved.

BP-1550

When searching the
HealthLink online directory for
contacts, the Maximum
Distance search field is not
consistently enabled when a
postcode is entered.

No known workaround. Not yet
resolved

BP-1121
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Issue Workaround Fixed in Key

If a contact category has
multiple specialist codes
mapped, when searching for
the category plus either a
name or postcode, the results
returned include providers
that do not belong to the
category selected.

No known workaround. Not yet
resolved

BP-1122

From the Follow up Reminders
screen, selecting a reminder
and clicking Contact Notes will
only show those Contact Notes
specifically related to that sent
single reminder record, not all
contact notes associated with
the history of the reminder.

No known workaround. Not yet
resolved

BP-1004
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