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Setting up the Management module for the first time
After you have installed Bp Premier for the first time, or converted from a previous clinical software
package, you must apply a minimum of configuration to start using Bp Premier. The following provides
a general overview on how to set up the components of theManagement module of Bp Premier.

Before you begin:

log in to Bp Premier on the server and each workstation and confirm the connection to the Bp
Premierserver
enter a valid Bp Premier licence key into the server. If you do not have a licence key, contact Gen-
eral Products Support on 1300 401 111.

If you have already set up the Clinical module of Bp Premier, you may have already performed some of
the steps below. See Setting up the Clinical module for the first time in the Bp Premier Knowledge
Base for more information.

Complete each section in sequence. Best Practice Software appreciates that it can take some time to
configure software to completely suit a practice's preferences and workflows. All of the settings
described in this section can be reversed or changed at any later time.

MANAGEMENTMODULE ADDITIONAL FEATURES

When a licence key that has the Bp Premier Management module enabled is entered into Bp Premier,
additional toolbar icons and menu items become available.

On themain menu, aManagement heading appears in themenu options. New icons will appear for
the Appointment Book andWaiting room, depending on the user's permissions within Bp Premier.

Additional preferences will appear for each user in the Setup >Users screen, as well as a Set Reports
button to give users access to Management reports. Three new options under the Setupmenu option
will configure Sessions, Practice fees, and Cheques.

The Setup > Configuration screen will have new tabs to configure Appointments, Billing, SMS, Account
text, Payer allocation, Bank accounts, and Work Cover details.

SET DATE, TIME, AND REGION

TheWindows operating system on the Bp Premier server must have the region, date/time format, and
time zone set to 'Australia' for Bp Premier to function correctly. If the date/time format is set to an
American usage, for example, Bp Premier may not be able to synchronise with third-party software like
messaging services and My Health online.

1. On the Bp Premier server, open the Control Panel and select Date and Time. Alternatively, click
once on the clock in the bottom right of the desktop and select Change Date and Time Settings.
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2. Set the Time Zone to your Australia time zone and enable daylight savings if your state uses day-
light savings.

3. From the control panel, select Region.
4. Set the Format to 'English (Australia)'.
5. Set the short date format to a format that lists date, then month, then year. For example,

'd/MM/yyyy' or 'd/MM/yy'. Do not use a month-first format.
6. Select the Location tab and set the Location to 'Australia'.
7. Click Ok to save and exit the Region dialog.

ENTER PRACTICE DETAILS

If you have converted your data into Bp Premier from another package, the practice details will con-
tain the same information as the old system.
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If you are starting from an empty database, you are prompted to enter the practice details when you
first log in to Bp Premier.

Note: Ensure your practice details are correct. Bp Premier uses the practice information entered
when printing items like scripts, invoices, and receipts.

There is only ever one practice name in the software. However, you can createmultiple practice loc-
ations to be printed on scripts, invoices, and reports. Users select a location when the user logs in to
the software.

To add practice details:

1. Select Setup > Practice from the Bp Premier screen. The Practice details screen will appear, show-
ing:

practice name
a summary of howmany licenced users you have
the licence expiry date
each practice locations that are set up
contact details for the first location on file.

2. Click Change. The Practice details update screen will appear.

3. Update any details and click Save.

Theremust be at least one location record. Most practices will have only the one practice location.
However, you can createmultiple practice locations. Location details are printed on scripts, invoices,
and reports.

To add a location:
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1. Select Setup > Practice from the Bp Premier screen. The Practice details screen will appear.
2. Click Add next to the Practice Locations list field. The Location details screen appears.

3. Complete the details for this location and click Save.

The Rural / Remote area checkbox controls which Medicare incentive is added to bulk-billed
invoices for pensioners, health care card recipients, and children. If unticked, incentive '10990' is
used; if ticked, '10991' is used.

LSP Number is the Location Specific Practice Number used when practices provide diagnostic ima-
ging services or radiation oncology services.

To delete a location:

1. Select the location on the Practice details screen and click Delete. A prompt will appear if any
users have provider numbers linked to that location.

2. If the location is deleted, users with linked provider numbers will still be visible, but the provider
number linked to that location will no longer be visible.

To restore a deleted location:

1. Select the Show Deleted checkbox at the bottom of the screen to view deleted locations.
2. Select the deleted location in the Practice locations list field and click Restore.
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CONFIGURE BILLING
1. Turn off links to a prior billing package

If the practice previously used a third party billing package and had a link established to transfer inform-
ation between Bp Premier and this third party package, it will be necessary to disable this link.

To turn off the link, untick the selection Activate the link to another package. This will grey out all
the paths and disable the linking process.

Note: Disable this setting on each workstation.

2. Set up billing preferences

The Billing tab of the Configuration screen sets up the way accounts, payments, invoice and receipts
work at your practice.
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Configure the fields in this screen to suit your practice's preferences.

Field Description

Default billing Sets the default billing type when new providers are added.

New patients Sets the default billing type when new patients are added.

Billing precedence Determines whether the doctor's or patient's billing type is used as the default when creating
accounts. The billing type can be changed before printing or saving the account:

If set to 'Doctor', all patients seen by that doctor will be billed according to the doctor's
default billing.

If set to 'Patient', the patient will always be billed according to the patient's billing type.

Payment Type Determines which payment type will be selected when you first open the Payments screen:
None, Cash, EFT, or Credit card.

Default to the
patients usual doctor
for new accounts

If ticked, all new accounts generated from the Create Account screen will be billed to the
provider listed in the patient's usual doctor field in the patient's demographics record.
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Field Description

Enforce entry of
reason for cancelling
payments and
invoices

If ticked, users must enter a reason for cancelling payments and invoices.

Create separate
accounts in Debtor
list for each doctor

If ticked, the debtor list will generate separate debtor statements for each doctor and a drop
down box will appear on the ‘Debtor list screen to allow you to select the doctor. If unticked,
the ‘Debtor list screen will produce debtor statements for the practice rather than each
doctor.

Print practice name
on accounts, receipts
and statements

If ticked, the practice name and address entered in the Setup > Practice details > Edit screen
will be printed on all accounts, receipts, and statements. If unticked, the doctor's name and
details will be printed on all accounts, receipts, and statements.

Prevent Direct Bill
vouchers without
Medicare and DVA
no.

If ticked, accounts which are direct-billed to Medicare or DVA can't be entered if the
Medicare number or DVA number is not recorded on the patients demographic record. If
unticked, accounts can be direct-billed if the Medicare number or DVA number is not
recorded.

Allow invoices with
no services to be
printed

If ticked, accounts that do not contain any services can be printed.
If unticked, blank accounts can not be printed.

Print invoices and
receipts on A5 paper

If ticked, all invoices and receipts will print in A5 format. If unticked, all invoices and receipts
will print in A4 format.

Print header on
invoices and receipts

If ticked, all invoices and receipts will have the practice or doctor details printed at the top of
the page (see also setting for Print practice name on accounts, receipts and statements). If
unticked, nothing will be printed at the top of invoices and receipts. The letterhead will be
used.

Bill direct to
insurance company if
known

Tick this box if you want any accounts created for the patient to default to bill to the
insurance company noted on the patient's demographics record.

Prompt when there is
a duplicate service on
the same day

Tick this box to display, when saving an invoice, if an item number listed on the invoice has
already been billed that day.

Print Medicare No
and DoB on Invoices
and receipts

Tick this box to print the patient's Medicare number and date of birth in their invoices and
receipts.

Print health insurance
fund details on
invoices and receipts

Tick this box to print a patient's health care fund details from their demographic record in the
patient's invoices and receipts.

Include outstanding
balance on Invoices
and Receipts

Tick this box to print outstanding balances on invoices and receipts.
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Field Description

Include Practice in the
list of billing
providers

Tick this box to include the provider's practice in the list of billing providers when creating an
account.

Default to DVA list
for DVA accounts for
Allied Health
Professionals

Tick this box to display the Allied Health DVA item list when creating accounts for DVA
patients.

Include Services when
using ‘Use previous
account button

If ticked, the Use previous accounts function is available when creating an account to default
to, including services.

Round GST to the
nearest 5 cents

Rounds GST amounts up or down to the nearest 5 cents.

Apply Diagnostic
Imaging rules to
private accounts

Lava Service Pack 1 only.

Apply the multiple services rules for diagnostic imaging, as applied to Medicare and DVA
accounts, to private fee accounts also.

Check the 'Credit
payment...' box when
reversing a payment

Lava Service Pack 1 only.

When reversing a payment, tick the Credit payment to payer’s account checkbox on the
Reverse Payment popup by default.

If the Credit payment to payer’s account checkbox is ticked, the refunded amount will be
credited to the payer’s account. See Reverse an unbanked payment in the Bp Premier
Knowledge Base for more information.

Print name & address
on accounts and
receipts __ mm from
left of page

Adjusts where the name and address is printed on accounts or receipts from the left of page.

Start printing body of
accounts and receipts
__ mm from to top of
page

Adjusts where the body of accounts and receipts are printed from the top of the page. This
setting is useful if your practice prints on preprinted letterheads or forms.

Layout of Medicare
Claim form

Medicare regularly change the layout of their green claim form. This option allows you to
change the print format to match the form you are using. The form number is printed on the
bottom left hand side of the Medicare claim form.

3. Set up Account Holders

Accounts holders are companies and institutions that can be used as a third party account recipient
for patient accounts (for example, Insurance Companies, Employers, or Hospitals). Account holders
can also be used as an account recipient for non-patient accounts.
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1. From themain Bp Premier screen, select View > Account Holders.
2. Select Add new to add a new account holder.

4. Set the default account text

1. From the Configuration screen, select the Account text tab. This screen configures the text that is
printed at the bottom of accounts.

2. If your practice has multiple locations, choose the practice location to set account text for from
the Print for location field.

3. Set the different text based on the length of the overdue period for none, 30, 60, and 90 days.
4. Set theDiscount textmessage. This text is printed on any accounts that are billed at a rate called

'Discount'. Any text here can contain the placeholder%FEE%, which is replaced during printing
with the value of the account at the practice fee rate (not the discount rate).

5. Click Save.
6. Repeat steps 2-5 for each location you want to set invoice text for.
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5. Set up invoice notes

1. From the Configuration screen, select the Invoice notes tab. This screen sets up a standard set
of notes or service text that can be selected when creating Invoices.

2. Select Add to add a new invoice note.
3. Click Savewhen you are finished creating invoice notes.

Invoice notes help ensure that Medicare accounts are created consistently.

6. Set up payer allocation

Use payer allocation settings if an employee doctor's bulk bill payments are paid into the principal doc-
tor's bank account and distributed later.

1. From the Configuration screen, select the Payer Allocation tab. This screen directs bulk billing
payments to a provider other than the actual service provider.
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2. Click Add to add a new payer allocation. The Provider payment details screen will appear.

3. Select the providerwho is performing services. Payments to this doctor will be paid into an altern-
ate provider's bank account.

4. Enter the provider number for Medicare and DVA payments to be paid to. Payments will be
paid to the bank account of the provider entered into this field.
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7. Set up bank accounts

The Bank accounts tab configure bank accounts for your practice and providers.

1. From the Configuration screen, select the Bank accounts tab.

2. Click Add under Practice accounts to open the Bank account details screen for the practice.
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3. Complete the account details and click Save. You can add as many bank accounts for the practice
as you need.

4. Click Add under Provider accounts to open the Bank account details screen for a provider.
5. Complete the account details for the provider and click Save. You can add as many bank accounts

for providers as you need.

Tip: If the bank name you wish to use is not listed, you can add a new bank by selecting
Setup > Cheque details from the main Bp Premier screen.

8. Add bank names and drawer details

The Cheque details screen adds the names of banks that are available when adding cheques to the Pro-
cess Payment screen.
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1. From themain Bp Premier screen, select Setup > Cheque details.

2. Click Add next to theDefault bank names list to add a new bank name.
3. Click Add next to theDefault drawers list to add names of payers who regularly pay by cheque.

The names in this list will be available in theDrawer list when adding cheques to the Payments
screen.

4. Click Save.

9. Set up WorkCover defaults

TheWorkcover tab of the Configuration screen records details that will be used on accounts when
'WorkCover' is selected in the Create account screen.
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Note: These details would most likely be used in Queensland where there is a centralised facility
for Workcover. In other states, Workcover accounts are often issued to individual employers or
insurance companies.

CONFIGURE USERS
1. Add users

If you have not converted from a previous clinical management package, you will need to create
records for each staff member who will be using Bp Premier, including doctors, nurses, reception staff,
and practicemanagers.

If you have converted from other management software, you will need to configure the converted
users to match your practice's workflows in Bp Premier, and to grant permissions to access reports
and functionality appropriate to each user.

You can create a new user in several different ways, depending on the user type and practice pref-
erence. See Adding a new user in the Bp Premier Knowledge Base for more information.
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2. Grant user permissions

When a new user is added, Bp Premier automatically allocates permissions according to the Category
in theUser details screen. You can modify permissions from the default for individual users.

Note: If your practice has just enabled the Management module for the first time, Bp Premier
users that were in the system before enabling Management will have no management per-
missions. You will need to review their permissions before they can use any of the management
features.

See Adding a new user in the Bp Premier Knowledge Base for more information.

3. Grant user access to reports

Bp Premier provides dozens of reports with theManagement module. When you add a new user, Bp
Premier will prompt you for the reports the user has access to.

Important: Only certain categories of user will prompt for reporting permissions when cre-
ated. Other categories, such as 'Nurse' or 'Junior receptionist', will not be granted access to
reports by default. You will need to set the Reports permission on the user's Permissions
screen to 'Allow access' to enable the Set Reports button.

If you change a user's Category, Bp Premier will prompt you to reset the user's reporting
permissions to the defaults for the new categroy.

1. Open theUser Details screen for the user.
2. Click Set Reports. The Setup reports screen appears.
3. Select the Report Types in the top right you want to grant access to: New, Old, or All. The report

types will be displayed in the list of reports on the left hand side.
4. Tick each report you want to user to be able to run.
5. Set the Practitioner Access:

All Practitioners — The selected reports will contain data from all practitioners at your prac-
tice.
Self Only Access — The selected reports will contain data only from patients and data for the
current user.

6. Select the locations included in the reports from the Locations Access list.
7. To apply the settings on the right hand side to all selected reports, click Apply to all ticked

reports. Otherwise, repeat steps 4-6 to configure access to individual reports.
8. Click Save.

See Setting up users to run reports in the Bp Premier Knowledge Base for more information.

4. Set user preferences

Preferences are set per individual user. Any user can update their own permissions as long as they
have the relevant permission set in their user account.

See Adding a new user in the Bp Premier Knowledge Base for more information.
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CONFIGURE SESSIONS

Appointment book sessions determine the first and last sessions available at your practice and for
each provider, as well as:

lunch breaks
public holidays and practice closing periods (for example, an office Christmas break shutdown)
consultations outside of regular hours
'on the day' times for walk-ins and on the day appointments
rostered times for providers on a 1-4 week roster cycle.

See Setting up appointment book sessions for practice and providers in the Bp Premier Knowledge
Base for more information.

CONFIGURE FEES

Bp Premier Management is distributed with the fee schedules for Medicare and the Department of Vet-
erans Affairs.

The built-in practice fee defaults to theMedicare Benefits Schedule fee for each Medicare item. MBS
schedules are available for use in the Account details screenwhen creating an account. TheMedicare
and DVA fee schedules cannot be changed nor added to by the user.

However, the practice fee schedule can be changed and can have other items added to it, and other
fee schedules can be added, for example, AMA fees, or Workers Compensation fees.

Fees are configured by selecting Setup > Practice fees. The Setup practice fees screen will appear.
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Add custom fee schedules

So that you can group custom fees when creating an account, you can set up as many custom fee
schedules as your practice requires.

When staff are processing an account from the Account details window, all fee schedules that you
have set up will be listed in the Billing schedule list. After you have selected a billing schedule from this
list, any items added to the account will automatically use the fee for that item.

1. To add a fee schedule, click Add schedule at the bottom of the Setup practice fees screen. The
Fee schedule screenwill appear.
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2. Enter the name of the schedule and indicate the default calculatemethod. No calculation method
means users will enter the fees directly against the schedule.

3. Indicate the rounding method, if applicable.
4. Click Save to return to the Setup practice fees screen.

Note: If you create a fee schedule called “Discount”, any accounts generated using that schedule
will have the text from the Discount text field on the Configuration and Account text window
added at the time of printing.

Add custom items

Custom items are items not included in theMedicare and DVA fee schedules. At the top of the Setup
practice fees screen is a list of Customised Fees, which lists all items that have been customised by the
practice. This list will appear when finalising a visit or creating an account.

1. To add a custom item, such as AMA fees, click Add custom fee. The Setup fee item screen will
appear.
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2. Type in the item number and description of the item in the Item description field.
3. Select the fee schedule that you want to set this fee for and click Set fee. The Calculate fee screen

opens.

4. Enter the desired fee. For items that are not related to an MBS Item number, you can not select
Use schedule fee or Schedule fee + n %. Click OK to save the change.

5. The fee entered will appear against the fee schedule selected in step 3. Tick Apply the highlighted
amount to all customisable items in list to set this fee for all schedules listed.

6. Tick Add GST to this item when adding to account if the fee attracts GST.
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7. Click Save to save the fee. It will now appear in the Customised fee list.

Adding a practice fee to an existing MBS item

1. Double-click on an item in the Customised Fees list to display the Edit fee item screen. Select the
practice fee schedule and click Set fee.

2. From the Calculate fee screen, enter the practice fee to charge, or calculate the fee based on a
percentage of the schedule fee or by adding a fixed amount to the schedule fee.

3. The fee displayed will be saved for that item. This fee is static and does not change when the
schedule fee changes, even if it was calculated from the schedule fee.

4. This fee will now be used when creating accounts when the practice fee schedule is selected.

Adding a practice fee to a new MBS item

1. Click Set MBS item fee. The Set MBS Item fee screen will be displayed.

2. Enter the item number. TheMBS and DVA fees will be displayed in a list below the description of
the item.

3. Select Practice fee and double click or press the Set fee button to change the fee that will be
charged for it. The Calculate fee screen will appear. Enter the fee to change and click Save.
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CONFIGURE ALL OTHERMANAGEMENT SETTINGS
Set up eHealth

If the practice has not already been using Bp Premier for patient HI lookups and accessing My Health
Record, you must import the practice's certificates and set up eHealth.

See Preparing your practice for eHealth in the Bp Premier Knowledge Base for more information.

Set up Clinical lists

1. From themain Bp Premier screen, select Setup > Configuration. The Configuration screen will
appear.

2. Select the Lists tab.
3. Add entries relevant to your practice for the following lists:

Appointment Type—A set of standard appointment types have been provided with match-
ing icon. Create your own and assign your own icons.
Reason for cancelling appointments—A standard set of cancellation reasons, to save staff
typing in text each time a patient cancels an appointment.
Contact Categories—Types of contacts (third-party groups and providers) relevant to your
practice.

4. Click Save.

Set up appointments

1. From the Configuration screen, select the Appointments tab. This page sets up the default
appearance of your Appointment book.
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2. Configure the fields in this screen to suit your practice's preferences for handling the Appoint-
ment book.

Field Description

Start time Sets the time of the first displayed appointment slot.

End time Sets the time of the last displayed appointment slot.

These times are independent of the times set up for user sessions. If a user has sessions set up
outside these ranges, those appointment slots will not be visible from the Appointment book.

Tip: It is good practice to set these times one or two slots before and after the first and
last appointments of the day. Setting a buffer like this creates a margin at the top and
bottom of the appointment window that assists readability.
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Field Description

Appointment length Sets the basic length of an appointment slot.

All appointments in the system must be multiples of this length. If it is set to 15 minutes,
appointments can be made at 15, 30, 45, or 60 minute intervals.

If, for example, some doctors have appointments at 10 minutes length and other doctors at 15
minutes length, the Appointment length setting will need to be set to 5 minutes to show both
types of appointments on the same Appointment book.

Take the following into consideration:

You should carefully consider the length you set here. Too small an interval will result in a
large number of slots displayed, which may require more scrolling and decrease readability.

Since the Appointments window allows double and even triple booking into the same
timeslot, it may be more practical to use a 10 or 15 minute basic appointment length, and
use double bookings for users who need longer appointments.

Once this length has been set, changing it may result in appointments that have already
been booked not appearing properly in the Appointments window; the appointments that do
not correspond with the new times will be displayed at the next closest time after their ori-
ginal appointment time.

Note: Individual doctor's appointment lengths are set when setting up their sessions.

Refresh Interval Sets the number of seconds between each refresh of the Appointment book.

Minimum column
width (pixels)

Sets the minimum column width (in pixels) for each column on the Appointment book.

Default Day sheet
layout

Portrait or Landscape.

Display Sunday in
appointment window

Tick this box to include Sunday as a column in the display of week view in the Appointment
book. If this is not checked, Sundays can still be displayed when the Appointment window is in
day view.

Highlight row when
Time column clicked

This checkbox highlights an entire row on the Appointment book when the Time column is
clicked.

Pop up notes when
making an
appointment

Bp Premier records notes against a patient's name in the Appointment notes field on the
Patient demographics screen, and generates notes for items such as a patient has an
outstanding account, or is due for a reminder to be sent.

If the Pop up notes when making an appointment checkbox is ticked, notes are displayed on the
Add appointment screen when making an appointment.

Pop up notes when
patient arrives

If ticked, patient notes are also displayed in a popup when a patient is marked as 'Arrived' in the
Appointment book.
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Field Description

Check the Health
Insurance Fund
expiry date

If ticked, the Health Insurance Fund expiry date is checked when accounts are created and a
prompt displayed if expired.

Pop up notes when
creating account

If ticked, patient notes are also displayed in a popup when creating an account for the patient.

Colour booked
appointments
differently from
unbooked

If ticked, booked appointments are displayed in a pale blue colour. If not, booked and unbooked
appointments have the same colour in the same session.

Allow users to open
patient records from
other user's
appointments

If ticked, users who have access to open patient records will be able to start visits from other
user's columns in the appointment book.

This option is most commonly used if a practice has a treatment room that is used by many
staff, and will allow the next available person to take the appointment.

Allow users to
change the ‘Booked
by' name when
making
appointments

If ticked, users can change the name of the person who has booked the appointment when
creating the appointment.

Show Cancellation
list when an
appointment is
cancelled

If ticked, when an appointment is cancelled, the cancellation list will show any patients who are
waiting on an appointment to become available.

Include Inactive
patients when
making an
appointment

If ticked, both inactive and active patients are displayed in the patient search screen.

Require a reason
when cancelling an
appointment

If ticked, the user will be forced to enter a reason for cancelling and appointment.

Display appointment
type icons in
Appointment book
andWaiting room

If ticked, appointment book icons will appear next to appointments in the appointment book and
waiting room.

Don't display
appointment icon on
standard
appointments

If ticked, and the option Display appointment type icons... is ticked, standard appointments will
not have icons displayed. next to them.
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Field Description

Automatically show
attendance status on
appointment book

If ticked, an attendance icon indicates whether an appointment's attendance has been
confirmed or declined:

A green circle icon means that the appointment has been confirmed.

A red circle icon means that the appointment has been declined.

A yellow circle icon means that the appointment has been sent an SMS reminder, but has
not confirmed or declined the appointment.

No icon indicates that the appointment has not been sent an SMS reminder, and the appoint-
ment has not been confirmed or declined.

Show uncompleted
appointments in
Waiting room when
opened

If ticked, patients that are currently “With doctor” or “At billing” remain displayed in the
Waiting room screen.

If not ticked, the same patients are removed from the Waiting room screen as soon as the
doctor opens the patient record and starts a visit.

Allow patients to be
added directly to
Waiting room

If ticked, patients can be added to the Waiting room screen without having had an appointment
made in the Appointment book.

Allow patients to be
added to Waiting
room for ‘Any doctor

If ticked, patients can be added to the Waiting room screen without being allocated to a specific
doctor. Patients will be visible in all doctors' Waiting room screens, and any doctor can choose
to see them.

Set up SMS Reminders

See Setting up SMS reminders in the Bp Premier Knowledge Base for more information.

Set up Appointment book layouts

See Creating an Appointment Book layout in the Bp Premier Knowledge Base for more information.

CONFIGUREONLINE CLAIMING

Medicare online claiming is configured from theOnline claiming tab of the Configuration screen.
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See Setting up Online Claiming for single location in the Bp Premier Knowledge Base for more inform-
ation.
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Import and export contacts
You can import and export contact records between Bp Premier installations.

Export contacts

1. From themain menu, select View > Contacts. The Contacts screen will appear.
2. Select File > Export all contacts.
3. Browse to the folder where you want to save the export file. Change the File name from the

default if you want and set to Save as 'XML'.
4. Click Save to export the contacts to file.

Import contacts

1. On Windows XP orWindows 7, go to Windows Start > All Programs > Best Practice Software >
Best Practice > BP Utilities

On Windows 8 and higher, click on theWindows flag icon in the bottom right, select the down
arrow to view apps, and click on BP Utilities under Best Practice Software.

2. Enter a Bp Premier username and password into the login prompt. The Bp Premier Utilities
screen will appear.

3. Double-click the Import Contacts utility. The Import Contacts screen will appear.
4. Click Load File and browse to the folder containing the contacts export file. Click Open. The list of

exported contacts will appear in the Import Contacts screen.
5. Tick the contacts you want to import, or click Select All.
6. Click Import to import the selected contacts.

If contacts are imported from an older version of Bp Premier, you may need to update any new fields
in a contact record.

Page 30 Management Setup Guide



Importing patient records
If a new patient signs up or a new doctor begins work at your practice, they may be able to bring elec-
tronic copies of their patient records from a previous practice.

If the previous practice used Best Practice software or Medical Director 3, and the files have been expor-
ted as XML files, you can import the patient record into your Bp Premier installation. XML files have
the file extension '.xml'.

Files exported with the extension '.htm' or '.html' are HTML files that you view in an internet browser.
You cannot import patient records in HTML into Bp Premier. You could print the pages from a browser
and scan the printed copies into the new patient record, or you could ask the previous practice to
provide XML versions of the patient record (only if the practice uses Bp or MD3).

Important: If a patient already exists in Bp Premier before being imported, the patient
record will be duplicated and you will have to merge the two records. SeeMerging Patient
Records on page 33.

Importing patients with custom preparations

From Lava Service Pace 1, custom preparations prescribed to patients will only be imported from an
exprted patient record if the Site ID of the patient record file and the Bp Premier server being imported
into are the same. If a patient record is imported into a Bp Premier database with a different Site ID,
custom preparations will not be imported.

IMPORTINGA SMALL NUMBEROF PATIENT RECORDS

Use this method when you only have one or two patient record files to import.

1. On Windows XP orWindows 7, go to Windows Start > All Programs > Best Practice Software >
Best Practice > Patient Import-Export.

On Windows 8 and higher, click on theWindows flag icon in the bottom right, select the down
arrow to view apps, and click on Patient Import-Export under Best Practice Software.

2. Log in using your username and password.
3. Click Import Single Patient.
4. Browse to the location of the patient XML and select the file you wish to import.
5. Bp Premier will check that the XML file is in the correct format. If any issues are found, a message

will be displayed and an entry written to the BPS Bulk Export Error.log file with more information.
The XML file may be in a format that Bp cannot import, or the file may have been edited or cor-
rupted and contain errors.

6. If the file can be imported, Bp Premier will import the patient record and display a message to
indicate that the patient has been successfully imported.

7. The patient will now appear in Bp Premier.
8. Repeat steps 3–5 for each individual record you want to import.
9. Click Close to close the Patient Import-Export utility.
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IMPORTINGMULTIPLE PATIENT RECORDS

Use this method if you have an entire folder of patient records in XML format you wish to import into
Bp Premier, for example, loaded onto a memory stick. Theremust be no other files in the folder.

1. On Windows XP orWindows 7, go to Windows Start > All Programs > Best Practice Software >
Best Practice > Patient Import-Export.

On Windows 8 and higher, click on theWindows flag icon in the bottom right, select the down
arrow to view apps, and click on Patient Import-Export under Best Practice Software.

2. Log in using your username and password.
3. Click Import bulk patients.
4. Browse to the folder containing the patients record to import. Click OK.
5. Bp Premier will check that all XML files in the folder are in the correct format. If any issues are

found, a message will be displayed and an entry written to the BPS Bulk Export Error.log file with
more information. The XML file may be in a format that Bp cannot import, or the file may have
been edited or corrupted and contain errors.

6. Note down the name of any file that is not in a valid format. You will need to obtain a correct ver-
sion of the file after the bulk import process and import the patient record individually.

7. At the end of the import process, a message will indicate howmany patient records have been
successfully imported.

8. Click Close to close the Patient Import-Export utility.
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Merging Patient Records
If your practice has converted to Bp Premier from a previous clinical application, you may have duplic-
ate patient records present in the database. You can merge patient records from the Patient list
screen.

To merge two patient records that have the same patient name, you select one record to keep, and
one record to merge with the kept record and be removed from the database.

Important: Merging patient records is permanent and cannot easily be reversed. User per-
mission to merge patients should only be granted to senior practice staff.

Themerge process depends on whether your practicemaintains a link to a third party billing package.

MERGINGPATIENTS IN AN UNLINKED BP PREMIER INSTALLATION
1. Select View > Patients from themain screen. The Patient list screen will appear.
2. Search for the patient by surname, firstname. Both records should be listed in the patient list. The

records will have the same name and details.
3. Select the patient record that you want to keep.
4. Select Edit >Merge from themenu. If theMerge option is not available, speak to your system

administrator to have the user permission added.
5. Read theMerge Patients warning prompt that appears. If you are sure you have the right

patient, click Yes.
6. Search for the patient to merge by surname. The patient selected here will bemerged with the

first patient and the record removed from the database.
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7. Select the patient and click Select.
8. The second patient record will now be removed and any notes, results, documents, and patient

data recorded for the patient will bemoved to the patient selected in step 3.

MERGINGPATIENTSWHEN LINKED TOA THIRD PARTY BILLING
PACKAGE
Adjust the patient file to identify which record is linked to Bp

This step requires you to edit the patients file in a linked installation. See Linking to a third party
billing package in the Bp Premier Knowledge Base for more information.

1. Open the patients file in the billing package.
2. Adjust the patient street demographic. For example, change 'St' to 'Street', or someminor, easily

identifiable change.
3. Allow the changes to be updated to Bp Premier. This can take up to 1minute.
4. Open the duplicate records in Bp Premier to identify which record has been updated by the

change. The updated record will be the 'kept' record when you merge in the next step. If the
other record has not been updated by the change, it is 'unlinked' and can safely bemerged.

Important: If a duplicate patient record exists in the billing package, then a matched record
should exist in Bp. Do not proceed. Contact your billing package vendor to discuss duplic-
ated records in the billing package prior to revisiting this procedure.
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Merge the unlinked duplicate to the linked patient record

1. Select View > Patients from themain screen. The Patient list screen will appear.
2. Search for the patient by surname, firstname. Both linked and unlinked records should be listed

in the patient list.
3. Select the linked patient record.
4. Select Edit >Merge from themenu. If theMerge option is not available, speak to your system

administrator to have the user permission added.
5. Read theMerge Patients warning prompt that appears. If you are sure you have the right

patient, click Yes.
6. Search for the unlinked patient record. Select the patient and click Select.
7. The unlinked patient record will be removed and any notes, results, documents, and patient data

recorded for the patient will bemoved to the patient selected in step 3.
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Backing up and restoring Bp Premier
Best Practice Software recommend that you back up your Best Practice data daily using the supplied
utility BP Backup, even if you use a third-party backup utility. BP Backup provides the simplest restore
of the database. Best Practice Software Support staff can assist you with backing up and restoring the
database through BP Backup, but may be unable to assist with restoring a database through third-
party backup software.

Best Practice also recommend that a test restore of the backup is performed to a separate server on a
regular basis to ensure that your backups are valid and can be restored. Store backups off-site in a
secure location.

You can manually back up the database at any time, but it is better practice to set up a scheduled
backup to run overnight or during a time ofminimal server activity.

If you are experiencing problems with the backup process, see Troubleshooting backups on page 41.

Note: Users performing backup and restore operations will require some or all of the Con-
figuration, Perform a backup, and Perform a restore permissions set to 'Allow access'.

PERFORMINGAMANUAL BACKUP
1. Log into Windows on the Bp Premier server as a Windows Administrator user.
2. On Windows 8 or later, select theWindows logo in the bottom left > Apps > BP Backup.

On Windows 7 or earlier, select Start > Programs > Best Practice Software > Best Practice > BP
Backup.

3. The BPS Backup Utility screen will appear. Click Backup database. Enter the username and pass-
word of a Bp Premier user with the permission Perform a backup set to 'Allowed'. A file explorer
will open.

4. Browse to the folder you want the Best Practice Software backup file to be stored.
5. From the Save as type drop-down, select the type of compression. This step is optional.

A compressed backup creates one zip file containing a file for each Best Practice database and
requires free space on the Bp Premier hard disk at least three times the size of the database, to
allows creation of temporary files.

An uncompressed backup creates one file for each Best Practice database.

6. Click Save. The filenamewill default to a timestamp format, for example, 'BP_20080513105335'.

After the backup has completed, BP Backup will notify the success or failure of the backup. Best
Practice Software recommend that you copy or move the backup files to an external device that can be
stored in an off-site location.

SCHEDULINGA BACKUP

Scheduled backups allow you to back up Bp Premier data while the system is unattended, and sched-
ule a backup several times a week or on the same day (a lunchtime and evening backup, for example).
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Important: Prior to Bp Premier version Lava, scheduled backups were configured through
the Bp Link utility. If you have upgraded to Lava, Best Practice Software recommend run-
ning scheduled backups through the Bp Service instead. See Configuring Bp Link as part
of the BpService in the Bp Premier Knowledge Base for more information.

1. Select Setup > Configuration > Bp Service tab.
2. Click Configure Automated backup. The Scheduled backup screen will appear.

3. Tick Perform scheduled backup.
4. Set a Default backup folder to store backup files in. You can override this setting when you cre-

ate a schedule.
5. Click Add to add a new schedule. The Backup details screen will appear.
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6. Select theDays of week to run the backup.
7. Select the Backup time to run the backup.
8. Select the Backup folder to store the backup files. Ensure the hard disk has enough space for the

backup process and files. If you are running an uncompressed backup and the backup folder is
on a network, you must use a mapped drive. UNC paths are not supported.

9. Select Compressed to run a compressed backup. Compressed backups require free space on the
Bp Premier hard disk at least three times the size of the database.

Note: Ensure that the destination directory for backups has permissions set to allow
read/write/delete. Set the permissions level to 'full control' for the 'network service' user-
name. Your IT support can assist.

10. Click Save to return to the Scheduled backup screen.
11. If you do not wish to keep old backup files, tick the checkboxDelete old backups in the same

folder.
12. Tick Send message if backup fails and select one or more Bp Premier users if you want staff noti-

fied if a backup fails.
13. Click Save to exit.

RESTORING THE DATABASE
1. Log all users out of Best Practice. Restoration will replace all existing data.
2. Log into Windows on the Bp Premier server as a Windows Administrator user.

Important: When restoring, always log in to the Bp server on the local machine or
through a console connection. If you attempt to restore the database through a
Remote Desktop session, Bp Premier will return an SQL error and will not restore.

3. On Windows 8 or later, select theWindows logo in the bottom left > Apps > BP Backup.

On Windows 7 or earlier, select Start > Programs > Best Practice Software > Best Practice > BP
Backup.
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4. The BPS Backup Utility screen will appear. Click Restore database. A file explorer will open.
5. Browse to the folder where the backup file is stored that you wish to restore.
6. Select the file to restore and click Save. The restore process will begin.

BACKINGUP AND RESTORING INDIVIDUAL DATABASES

You can back up and restore an individual database on the Bp Premier server only by using sqlcmd at
the command prompt screen.

To use sqlcmd, you will need to set up your bpsviewer account password. You may need to reapply
your database browser password if you have recently upgraded, because the BPSBackup account may
not yet be associated with the correct password.

The following are two examples of using sqlcmd:

Back up the active BPSPatients database:

sqlcmd -U BPSBackup -P <pwd> -S \BPSINSTANCE -Q "BACKUP DATABASE <database> TO DISK-
='<path>'"

Restore a backed-up BPSPatients database:

sqlcmd -U BPSBackup -P <bp pwd> -S \BPSINSTANCE -Q "RESTORE DATABASE <database>
FROM DISK='<path>' WITH REPLACE"

where:

<pwd> = the bpsviewer account password
<database> = the name of the database
<path> = the path and filename of the backup or restore file.

For example:

sqlcmd -U BPSBackup -P password123 -S \BPSINSTANCE -Q "BACKUP DATABASE BPSPATIENTS
TO DISK='c:\backups\bpspatients.bak'"

3RD PARTY BACKUPS

Third-party backups are not supported by Best Practice Support. The Best Practice support team are
unable to provide comprehensive support to sites trying to recover a backup performed by a third-
party product.

When using a third-party backup software that has an SQL agent, the user details required to access
the database are set in Setup > Configuration > Database:

User: BPSBackup
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Password: See Accessing the database through the 'viewer' account in the Bp Premier Knowledge
Base for more information.

Important: Do not lose the password that you set for this account, because it cannot be
reset. Store the password in a secure location such as the practice safe.
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Troubleshooting backups
The following steps address some common problems encountered when backing up the Bp Premier
database.

Best Practice Software recommend that you:

back up your Bp Premier data at least daily
store backup files off-site in a secure location
test restores of backup data to a test server at least monthly.

The source of failed backups often includes:

Lack of disk space on c:\ drive
No permission within Windows to write files to the destination drive
Issues with corrupt storagemedia (for example, damaged DVDs).

Identifying if the backup has worked

1. Check the backup log.

Each time a backup is performed, a record is written to the log file BPSBackup.log. This file can be
found in the folder:

Windows 2000, XP, or 2003 Server — C:\Documents and Settings\All Users\Application
Data\Best Practice\Log
Windows Vista, Windows 7 or 2008 Server — C:\ProgramData\Best Practice\Log.

This log contains a record for each backup, whether it was successful or not, and if the backup
was compressed or uncompressed.

Examples of log file entries include:

*********************************************

Date: 10/12/2009 Time: 12:19:44

Backing up to H:\, Compressed

Backup failed - There is not enough free space on the destination drive for this backup!

*********************************************
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Date: 10/12/2009 Time: 12:22:55

Backing up to H:\, Compressed

Backed up to H:\BP20091210122218.zip

*********************************************

Date: 10/12/2009 Time: 12:39:27

Backing up to H:\, Uncompressed

Backed up to H:\BP20091210123908.bku

2. Check that the files have been created on the destination drive.

The backup log lists the location in which the backup files were created. Browse to this folder to
ensure that the backup files exist.

To check the size of your database

1. Log in the Bp Premier server and go to Help > About > System info. The Server data path shows
the location of your data.

2. Browse to this folder, right-click on the folder name and check the properties. You will need
approximately three times this size free on the hard drive on which the database is installed.

3. If the hard disk on the server is short of disk space, consider an uncompressed backup, or back-
ing up to a network location.

Restoring to a test server

It is good practice to perform a restore of the backup on a test server. This is recommended because
backup media is often damaged in transit.

Test servers have two benefits: you can regularly test that your backups are working, and also provide
a fallback should your main server fail. If the practice has only a few users, you may be able to use a
medium specification PC as a test server. However, at larger practices, you would require a higher spe-
cification for the PC or even a true server machine.

Install Bp Premier on the test server with the same version as the live server, and upgrade the test
server each time a drug and data update and program update are released. The test server alsomust
have the same SQL version as the live server.

Discuss your backup process with your IT support company when you are discussing your disaster
recovery plan.

Compressed and uncompressed backups

Compressed backup pros:
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creates a single zip file containing a file for each Best Practice database
this one file ensures that you have the entire backup in one simple file no chance ofmissing data

Compressed backup cons:

much slower than uncompressed backups
requires plenty of free space on C:\drive of the server to create temporary files during the zipping
process.

Uncompressed backup pros:

Much quicker than compressed backup
Good to use if you have limited disk space on c:\drive

Uncompressed backup cons:

creates one file for each Best Practice database so have to ensure that all files are stored together
in case a restore is required
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