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About this guide
This guide describes how to prepare and upgrade an existing Bp Premier installation to Bp Premier
Lava Edition Service Pack 1 from the following versions:

Bp Premier Summit 2014 Edition (1.8.4.642)
Bp Premier Lava Edition (1.8.5.754)

To see which version of Bp Premier you have installed, select Help > About from themain screen.

The following sections describe how to upgrade Bp Premier, depending on your current version:

Bp Premier Upgrade Checklist - Lava

Follow the instructions in this section if you are upgrading from Bp Premier Summit 2014 Edition
(1.8.4.642).

This upgrade includes the Lava Edition, which contains major changes to the software and several new
features, including:

Support for multiple practice locations
Support for multiple provider numbers
Newmanagement report module

TheUpgrade Checklist - Lava edition contains instructions for preparing your staff and practice to
accommodate themajor changes in the software. It is critical that you familiarise yourself with the new
functionality before upgrading, because the changes will affect the workflow at your practice, and staff
will need to bemade aware of the new reporting module and how it affects the way you pay providers
at your practice.

After following the instructions in this section, review the new features available in Lava Service Pack 1
that are also included in the upgrade.

Bp Premier Upgrade Checklist - Lava SP1

Follow the instructions in this section if you have already upgraded your Bp Premier installation to the
Lava edition.

The Lava Service Pack 1 edition contains fewer major changes to the software, but your staff will need
to bemade aware of changes to the software, including:

Support for multipleMinor ID numbers
Setting up online claiming for multipleMinor ID numbers
Payment reports, transaction reports, and the Reversed Payment report now include details on
bounced cheques.

Downloading Bp Premier Lava version from the website

Follow the instructions in this section if you are unable to receive your upgrade DVD by mail. You can
download an executable installer from the Best Practice Software website to run locally.

Upgrading to Bp Premier Lava using the Lava edition installation DVD
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Follow the instructions in this section if you have received your Bp Premier Lava Service Pack 1
upgrade DVD and have completed your preparation according to the Lava or Lava SP1Upgrade Check-
list. These instructions assume you are ready to install and provide guidance through the installation
process after you have inserted the DVD.

Page 4 Lava Service Pack 1 Upgrade Guide



Bp Premier Upgrade Checklist - Lava
The information listed in the tables below should be considered prior to, during, and after upgrading
your current version of Best Practice Premier to the Bp Premier Lava edition.

Practice details for upgrade

Centre Name: IT Professional Name:

Staff member managing
upgrade:

IT Professional Contact
number:

Upgrade date and time:

STEP 1: PREPARE THE PRACTICE FOR UPGRADE

ü Item Further Information

Staff Training Ensure staff have been briefed on up-coming changes. We recommend that
everyone is provided with a copy of the What’s New in Lava document and
that any significant changes are discussed in a staff meeting. Videos and
other information will also be available via the Best Practice Software
website.

Sign up for our free Webinar series featuring all that you need to know
about Lava. Keep an eye on our website and newsletter for dates and times.

Reports Plan your upgrade around an end of financial period event such as end of
month or after a disbursement period. This will allow you to cleanly cut-over
to the new reporting system.

Notify your bookkeepers / accountants of the pending changes to the
reporting functionality. Major changes have been made to the reporting
module and the adjustment features available in the accounting screens.

See Using the new reports to pay providers in the Bp Premier Knowledge
Base for more information.

Check the Program upgrade
documentation for any
prerequisites required
before upgrading

Is the prerequisite program version already in use at the practice?

Is the prerequisite drug database version already in use at the practice?

Contact your IT
Professional

Discuss the upgrade with your IT Support Professional. Best Practice
Software recommend confirming the following topics:

Ensure the correct 3rd party software or drivers will be available during
the upgrade

Discuss upgrade timing

Discuss disaster recovery and ensure you have a tested rollback plan.
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ü Item Further Information

Prepare for changes
related to Multi-Location
functionality

The Lava release has enhanced support for multi-location functionality. In
preparation for this change, centres with multiple locations can start
preparing for this change by identifying and configuring a ‘primary’ account
for each provider.

Complete the following steps:

Identify the 'primary' user record for providers with multiple accounts

Update all sessions to ensure they have a location set

Adjust any aliases in the Incoming Reports screen to ensure reports will
now come through to the primary user account

Adjust any required preferences for the primary user

Adjust any permissions for the primary user

Adjust any favourites or auto-fill information for the primary user.

Back up the database and
test your backups

Perform a backup and test that the backup can be restored to a test server
to ensure that backups are working as expected.

STEP 2: UPGRADE BP PREMIER

ü Item Further Information

Download the program
upgrade utility

Ensure that the program upgrade utility is copied to all workstations. This
will assist with eliminating any last minute issues you may have copying
files to workstations during the upgrade process.

Ensure sufficient time is
allocated for the upgrade
process to occur

Ensure your IT Professional has allocated adequate time for the upgrade to
run. Best Practice Software recommend that all upgrades are completed
before or after business hours.

Perform a backup prior to
upgrade

Ensure that a successful backup is taken immediately prior to the upgrade
occurring and that no users log in again until the server has been upgraded

Upgrade the server before
any workstations

Terminal Server sites - ensure that all users are logged off the server prior
to starting upgrade

Laptops – ensure that all laptops that have downloaded data are returned to
the practice and synchronised with the server data before upgrading the
server

Test the upgrade Ensure that the upgrade is tested and considered successful before
workstation upgrades are started or the centre opens for business.

Upgrade all workstations Clients that are not upgraded to the new version will be unable to access
the management module.
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STEP 3: AFTER YOU UPGRADE

ü Item Further Information

Review the What’s New in
Lava document

Ensure the What’s New in Lava document is reviewed again to make sure
that you have not missed any important information.

Review new reports Identify the reports that will be required for your disbursement and end of
month reporting requirements. You may need to update internal
documentation referring to your payment and financial processes.

See Using the new reports to pay providers in the Bp Premier Knowledge
Base for more information.

Set up provider numbers
for each user with multiple
accounts

Following the upgrade, centres with multiple locations can now update their
provider user records with multiple provider numbers attached.

Note: This is not mandatory and you may wish to complete this at a later
stage.

See Moving to multiple
provider numbers in the Bp
Premier Knowledge Base
for more information.

If consolidating multiple user accounts into one, take into consideration the
following items:

Ensure that bank accounts and payer allocations are set correctly fol-
lowing the change.

Ensure all duplicate inboxes are emptied. Reports can be moved from
the duplicate account into the primary account one by one if required.

Ensure all clinical actions have been actioned or migrated to the primary
account.

Finalise billing of outstanding accounts.

Enable access to
Healthshare Fact Sheets

Healthshare Fact Sheets are now available within Bp Premier. To enable
access to these sheets, tick Enable HealthShare Factsheets in the General
section of a user’s preferences.
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Workflow changes from multiple practice locations
The following describes the changes to Bp Premier workflows and the user interface that regular users
will need to be aware of after you have upgraded to Bp Premier Lava.

LOG IN (ALL USERS)

Users who havemultiple provider numbers and used to havemultiple user names will no longer
see their name listed multiple times on the login screen.
It is VERY important that ALL USERS select the correct Locationwhen logging in as these details are
reflected on invoices, reports, scripts, etc.
Users with provider numbers will only see the locations which they have provider numbers for
Users without provider numbers will see all locations listed.

The user name at the bottom left of themain Bp Premier screen with show the user's name and cur-
rently logged in location.

GENERAL CHANGES

Many screens which previously had a provider drop down filter will now have either:

combined provider / location drop down filter or
individual provider drop down and location drop down filter or
single provider drop down which shows provider name (location)

Therefore when users are using these filters they may need to take this into account so that they see
the correct list of records.

APPOINTMENT BOOK - SESSIONS

Sessions have been able to be associated with a location for a while but this field was not reflected on
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the appointment book. This field is nowmandatory when creating sessions. During the program
upgrade, any sessions that did not have a location will have one assigned to it - this will be the default
location for the relevant provider. It is recommended that these sessions be checked to ensure that
they are set to the correct location.

To edit a session, select Setup > Sessions from themain Bp Premier screen. Select the user from the
drop down listed, highlight the first session and click Edit. Set the location for this sessions using the
Location drop down and press the Save button to update the session. Repeat this process with all
user sessions.

APPOINTMENT BOOK - LAYOUTS

Appointment book layouts have been available for a while. These have now been enhanced so that the
Layout drop down will now automatically show an appointment book layout for each location that has
sessions associated with it. There will always be a Default layout which will show all appointments for
all users regardless of location. When you select a location layout, the user list on the left will be filtered
to show only those users who have sessions at that location.

Depending upon the types of layouts you have already created it may be appropriate to delete obsol-
ete layouts using Setup > Configuration > Appointments > Appointment Book layouts. These loc-
ation layouts cannot however be customised as they are generated from the sessions in the system.

APPOINTMENTS - ADD / EDIT /MAKE APPOINTMENT

When you add a new appointment or edit an existing appointment, the location associated with the
session timewill show on the screen under the user's name.

.

Where there is no location associated with the session, a select locationwindowwill appear to allow
you to specify the relevant location.
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If no location is selected, the location showing on the add / edit appointment screen will display as
default.

APPOINTMENT BOOK - DAILYMESSAGE

These changes to cater for multiple provider numbers and locations means that it is now possible to
have a different daily message appear for different locations.

When you create a daily message there is a location drop down which allows you to select which loc-
ation it applies to. If a message is associated with the default location it will appear on all appointment
book layouts except when it is a location related layout which has its own daily message.

Any existing daily messages will be allocated to the default location during the upgrade.

WAITING ROOM

The Add to Waiting room screen has been change to allow the user to select a location. The location
selected will be the one associated with the appointment that is made and will override the location for
that session time. By default, the location will be the default location for the provider and can be
changed by clicking to the right of the location and selecting another location.

INCOMINGREPORTS

When results / reports are imported into Bp Premier, they are automatically allocated to a provider
and patient where possible. If allocated to a provider they are associated with the location related to
the provider number contained in the result.

The Incoming Reports screen is used to allocate results that were not able to be allocated auto-
matically. When you press the Allocate to Doctor button, the list of providers displayed now has pro-
viders who havemultiple provider numbers listed twice with the location in bracket after their name.
Users should attempt to link the result to the correct provider / location record if possible so it shows
correctly in the Follow up inbox.

Page 10 Lava Service Pack 1 Upgrade Guide



Regardless of which provider or location they are allocated to, they will still appear in a single Inbox for
the provider to allocate.

INBOX

a)When results and reports are imported, they are now automatically associated with the location
related to the provider number contained in the result. There will still however be only one Inbox per
provider so that all items can be allocated in the one screen.

Note: This requires that the users have been merged as outlined above.

When looking at the result in the Inbox, there is a new field called Store for Location. Documents
imported via the BDI will be allocated the location of the user importing the document.

If a result / report / document was imported prior to upgrading to this new version this Store for Loca-
tion field will be blank. While not absolutely necessary, we recommend that each user set this value as
they are actioning the item. The item will then be filtered correctly in the Follow up Inbox.

b)When creating a patient appointment using the File > Patient appointments > New appointment -
the location of each appointment will be shown in a column next to the appointment length.

FOLLOWUP INBOX

a) There is a new filter on the Follow up inbox screen to allow users to Split by location. This has the
effect of changing the Checked by drop down list to show providers multiple times if they have results
related to different locations. This would be useful if different users process results related to different
location. When splitting by location, selecting a provider that does not have a location next to their
namewill show any results that are not linked to a location.
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If this Split by location tick box is not selected then the Checked by drop down list will work as before.

b)When using theMake appointment button - the location of each appointment will be shown in a
column next to the appointment length.

PATIENT INVOICES / PAYMENTS

When creating invoices, a location drop down is located at the top right of the screen.

If the account is created from an appointment, the location shown will be the one associated with
that appointment.
If the account is created from theManagement screen, the location shown will be the current
users logged in location.

Once a provider is selected, if the provider selected is set as the patient's Usual doctor the
location will change to that provider's usual location.
The location can be changed manually by the user if required.

If the provider does not have a provider number for that location the system will use
the provider number for their usual location.
The address printed on the invoice will be the one for the selected location.

When entering payments, a location drop down is located at the top right of the screen.

Where a single invoice is being paid, the location will default to the location on the invoice being
paid.
Wheremultiple invoices are being paid, the location will default to the current user's logged in loc-
ation but can be change if required

ONLINE CLAIMING BATCHES

When creating online claiming batches, there is now an additional Location drop down. This has been
provided should your practice have different staff who are responsible for submitting claims for only
those providers at their same location.
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If a location is selected, the Provider drop down will only show providers who have invoices ready to
be sent for that location.

If the location is set to All, the Provider drop down will show all providers who have invoices ready to
be sent and will show the location in brackets after their name.

Both options will ensure that the batch created will only contain invoices which are linked to the pro-
vider number for the specific location.

PATIENT CLAIMING

Both themain Patient claims screen and theUnsent Claims screen will display a Location drop down
filter.

This filter defaults to All locations however if a location is selected the system will show only those
claims related to that location.

MANAGEMENT REPORTS

A new set ofManagement Reports have been included in this version to replace the older styled
reports. These reports have been produced to simplify the reporting process and providemany other
benefits.

All reports can now be grouped by location and/or provider.
These reports will utilise the location selected when creating the account or paying the account
Report parameters can be selected when generating a report so that reports can be printed for
individual or ranges of locations, individual or ranges of providers, ranges of items, ranges of pay-
ment types, etc. to give greater flexibility of how the report looks or is grouped.

In the past you often needed to print multiple reports to get all the data required and add totals
together (ie Cash, EFT, Direct Debit). These new report/s will combine all the data into one with
columns to separate totals. Reports also cater for adjustments showing original and adjustment
reports as relevant with values outside of the report range being shown but not included in overall
totals.

Refer to the section An overview of the NewManagement Reports for further details on how to use
these reports.

DEBTOR LIST

On theDebtor list screen, when you select Create Separate account for each provider both provider
and location drop down filters will appear enabling you to filter the list by a provider and / or location.

BANKING

On the Banking screen, when creating a batch and viewing theUnbanked payments there is now a
location drop down filter to enable the user to more easily separate payments by location if required.
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IMMUNISATIONS
When adding Immunisations into the patient record, the Billing provider and Given by fields will
now show the location next to the provider's name. If the provider works at more than one loc-
ation they will appear multiple time.
On the Australian Immunisations Register screen, a filter by location drop down has been
added to this screen to allow you to filter the list by provider and / or location. This would be
used if different users are responsible for sending the immunisations for each location.

WORD PROCESSOR
When logged in as a provider, the template fields under Current User such as full details and pro-
vider numberwill be those for the current logged in location.
When logged in as a non-provider, template fields under Provider will now show both provider
and location columns.

The location shown will default to the provider's usual location
An alternate location can be selected by clicking on the location field and using the blue
arrow.
Only locations for which the provider has a provider number are listed

MESSAGES

As a user with multiple provider numbers no longer need to have separate user records, messages are
no longer location specific. Therefore when creating a newmessage, users will only be listed once
which will ensure that they get messages no matter which location they are working at.

TheMessage screen has been restructured to show groups in the top and and users at the bottom so
it is less cluttered.

REMINDERS
When creating reminders, a newAt location drop down has been added to allow the user to
indicate which location as well as which provider the reminder is related to. It will default to the
user's current logged in location.
When using the Clinical > Reminders function to generate reminders, the Select patients for
reminders screen now has a Location section. This will show all locations that have reminders
associated with them and allows the user to generate reminder lists / letters for specific locations
if required. It is possible to set up Reminder templates that useUser Letterhead template field
rather than Practice letterheadwhich will pick up the location from the reminder and print the
correct address.
When reminders are created from an appointment, the reminder location will default to the one
associated with the appointment.
In other areas where you can create a reminder, the location will default to the user's logged in
location.

ACCOUNT TEXT

It is now possible to have different account text print on invoices and receipts depending upon the loc-
ation associated with that invoice or payment.
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Select Setup > Configuration > Account text from themain Bp Premier screen.

At the bottom of the screen is a Print for location drop down. Change this location to the one that
you want to customise the account text for and make any changes required then press the Save but-
ton. These changes will then be printed on accounts related to that location.
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Setting up multiple practice locations
This information assumes that at your practice all data is stored in the Bp Premier database on the
server, and the database is accessible by staff at your practice's different locations.

Bp Premier Lava introduces a number of improvements to streamline workflows for practices with mul-
tiple locations that share user and patient data. Follow the procedures below after you have upgraded
to Lava.

Multiple practice locations and multiple Minor IDs

In Bp Premier Lava, it is not possible to havemultipleMedicareMinor IDs within Bp Premier. All claims
received by Medicare will use the location selected on the Setup > Configuration >Online claiming
screen when transmitting. In Bp Premier, however, you can filter Medicare batches by provider and loc-
ation.

To register multipleMedicareMinor IDs in Bp Premier, you must upgrade to Lava Service Pack 1. See
Setting up Online Claiming for multiple locations on page 1.

ADDA LOCATION RECORD

There is only ever one practice name in the software. However, you can createmultiple practice loc-
ations; when a user logs into the software, they select a location, which will be printed on scripts,
invoices, and reports.

1. Select Setup > Practice from the Bp Premier screen. This will display the Practice details screen,
which shows:

practice name
a summary of howmany licenced users you have
the licence expiry date
the practice locations that are set up
contact details for the first location on file

2. Click Add next to the list of Practice locations. The Location details screen will appear.
3. Complete the details in the screen for the new location.
4. Click Save to add the practice location to practice details.

ADD THE USERSWHOWILL BEWORKINGAT THAT LOCATION

If the user does not currently have a user record in the database, create a new record using Setup >
Users > Add.

If the user has worked in the practice, edit their user details using Setup >Users > Edit.

TheUser details screen will appear.

If the user has a provider number:

1. Click to the right of the Provider No. field. The Provider Number Manager screen will
appear.
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2. Click Add. TheNew Provider Number screen will appear.

3. Enter the provider number, select the location associated, and click Save.

If the user does not have a provider number, set the user's usual location to be the one that they will
be working at most often.

Update the management reports that the user has access to

Click Set Reports and check that this user has access to the providers and locations for the reports
they need to print.
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LOG IN (ALL USERS)

Users who havemultiple provider numbers will only see their name listed once on the Login
screen, if the obsolete user accounts have been set to inactive. SeeMoving to multiple provider
numbers on page 20.
All users must select the correct Locationwhen logging in, because these details are reflected on
items such as invoices, reports, and scripts.
Users with provider numbers will only see the locations that they have provider numbers for.
Users without provider numbers will see all locations listed.

The username at the bottom left of themain Bp Premier screen will show the user's name and logged-
in location.

CREATE LETTERHEAD

Create a new letterhead in the word processor by selecting Templates > Edit Letterhead to reflect the
address details for the new location. The new letterhead will take effect when a template or letter con-
tains theUser letterhead template field and the user is at the new location.

CUSTOMIZE ACCOUNT TEXT

You can have different account text print on invoices and receipts depending upon the location asso-
ciated with that invoice or payment.

Select Setup > Configuration > Account text from themain screen.
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Change Print for location to the one that you want to customise the account text for. Make any
changes and click Save. Changes will be printed on accounts related to that location.

PAYERALLOCATION RECORDS

Payer allocation records allow you to specify that online claiming payments for one provider will be
paid into the bank account of another. The Select Provider drop down will now show the location in
brackets after the provider name to cater for circumstances where a provider is paid differently per loc-
ation.

ADD BANK ACCOUNTS

Add new practice and provider bank accounts for the new location.

Lava Service Pack 1 Upgrade Guide Page 19



Moving to multiple provider numbers
This information is for existing Bp Premier customers who have just upgraded, or are about to
upgrade to Bp Premier Lava.

Review the steps below to ensure that your system is ready to handle the newmultiple provider num-
ber functionality.

We recommend that you decide on a date and timewhen you will carry out the configuration. Ideally
this should be just after the update and before users log back into the system.

BEFORE YOU UPGRADE

If you have only one practice location:

ReviewWorkflow changes from multiple practice locations on page 8 to ensure your users
knowwhat will change that may affect their workflow.

If you havemore than one practice location:

Make a list of each person who has multiple provider numbers

Select Setup >Users from themain screen to display theUsers screen.

Record the Provider No. for each person and which location each is associated with.

Identify which record will be kept

most likely the one with their 'real' name.
open this user record and make sure that they have the correct 'default location' set.

For each user affected

1. Log in as the user which will be set inactive.
2. Read and action everything in their Inbox.
3. Read and action all messages.
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1. Log in as the user which will be set active.
2. Review the user preferences to ensure the user record being kept will work they way they expect

it to.
3. Check pathology and imaging preferences to ensure they have the correct custom tests and reas-

ons, favourite tests, and laboratory details.

Update all sessions to ensure that they all have a location set

Select Setup > Sessions from themain screen.
Open each session and make sure the session is associated with the correct location.

AFTER YOU UPGRADE

If you have only one practice location, you do not need to do anything more, because the program
upgrade will automatically update each user’s record with the correct provider number and location.
SeeWorkflow changes from multiple practice locations on page 8 to view changes to workflows and
the Bp Premier user interface for multiple provider numbers and locations.

If you havemore than one practice location:

Prepare to consolidate users

Identify users with multiple provider numbers and associated locations as described above.

Update practice details

Select Setup > Practice details from the Bp Premier screen. This will display the Practice details screen,
which includes:

practice name
a summary of howmany licenced users you have
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the licence expiry date
each practice locations that are set up
contact details for the first location on file.

Click Change. Update any details that need updating after the upgrade. Click Save.

Combine user details records

Using the list of providers and locations:

1. Identify one record per user to be retained as the user’s ‘active’ record.
2. Select Setup > Users > select the user name and click Edit. The Edit user details screen will

appear.

3. Check that all the user details are correct.
4. The Provider No. field appears in the top right hand corner. This is the provider number asso-

ciated with their usual location.

5. Click to the right of the number. The Provider Number Manager screen will appear.
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6. To add additional provider numbers, click Add. TheNew Provider Number screen will appear.

7. Enter the provider number and select the location that it is associated with and click Save.
8. Repeat steps 6–7 for each provider number for this user.
9. When all provider numbers are added, click Close to return to the Edit user details screen.
10. Click Save.
11. Repeat steps 1–10 for each user with multiple provider numbers.

Add pathology and radiology preferences to the user that will be retained

Each user you are changing should be advised that their records are being altered. Users should log in
as the user you have retained and update their pathology and radiology preferences.

Recreate sessions and appointments

If you use themanagement module, you will need to recreate sessions for the retained user if any ses-
sions exist for obsolete users.
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1. Select Setup > Sessions.
2. For each user record that will become obsolete, take a screen shot of all their sessions, extra ses-

sions, days away and 'On the day' appointments ensuring you can see all columns.
3. For the user record that will remain active, add sessions, extra sessions, days away and 'On the

day' appointments from the screenshots taken for the related users who will bemade obsolete.

If you use themanagement module, all appointments for the obsolete user records will need to be
moved to the active user.

1. Open the appointment book and change the layout to 'default' and the setting under the list of
users to ticked.

2. Tick the user names related to the user being updated so you have a column for each of their
related user records.

3. Copy and paste each appointment from the user that are to become obsolete to the same
appointment time slot for the user who will remain active.

4. Repeat for each user being updated.

Delete the sessions for the 'obsolete' user records.

1. Return to Setup > Sessions.
2. For each obsolete user, delete all sessions, extra sessions, days away and 'On the day' appoint-

ments.

Mark each obsolete user record as inactive

For each user record that will become obsolete:

1. Log in as the obsolete user, read all and clear theirMessages and To do list. Log out again.
2. Log back in and select Setup > Users. Select the record to bemade inactive and click Edit.
3. Tick Inactive.
4. Click Save. A warning message will appear: you will not be able to reactivate this user for seven

days.
5. Click Yes.

Update management report access

For each user record that will become obsolete:

1. Select Users > Set Reports and check that this user has access to the providers and locations for
the reports they will need to print.
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Bp Premier Upgrade Checklist - Lava SP1
The information listed in the tables below should be considered prior to, during, and after upgrading
your current version of Best Practice Premier to the Bp Premier Lava Service Pack 1 edition.

Practice details for upgrade

Centre Name: IT Professional Name:

Staff member managing
upgrade:

IT Professional Contact
number:

Upgrade date and time:

STEP 1: PREPARE THE PRACTICE FOR UPGRADE

ü Item Further Information

Staff Training Ensure staff have been briefed on up-coming changes. We recommend that
key staff review the Bp Premier Lava SP1 Release Notes and that any
significant changes are discussed in a staff meeting. Videos and other
information will also be available via the Best Practice Software website.

Sign up for our free Webinar series featuring all that you need to know
about Lava. Keep an eye on our website and newsletter for dates and times.

Upgrade timing The server upgrade should be performed outside of hours while Bp Premier
is not in use. Upgrade the server before upgrading any workstations.

Check the Release Notes
for any prerequisites
required before upgrading

Is the prerequisite program version already in use at the practice?

Is the prerequisite drug database version already in use at the practice?

Contact your IT
Professional

Discuss the upgrade with your IT Support Professional. Best Practice
Software recommend confirming the following topics:

Ensure the correct 3rd party software or drivers will be available during
the upgrade

Discuss upgrade timing

Discuss disaster recovery and ensure you have a tested rollback plan.

Prepare for changes
related to Multiple Minor
IDs

The Lava SP1 release has enhanced support for practices with multiple
locations who require multiple Minor ID Numbers. If this feature is
applicable to your practice, you will need to update your Medicare Online
Claiming configuration after install.

Back up the database and
test your backups

Perform a backup and test that the backup can be restored to a test server
to ensure that backups are working as expected.
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STEP 2: UPGRADE BP PREMIER

ü Item Further Information

Download the program
upgrade utility

(only if you are unable to
receive a Lava SP1 Upgrade
DVD)

Ensure that the program upgrade utility is copied to all workstations. This
will assist with eliminating any last minute issues you may have copying
files to workstations during the upgrade process.

Ensure sufficient time is
allocated for the upgrade
process to occur

Ensure your IT Professional has allocated adequate time for the upgrade to
run. Best Practice Software recommend that all upgrades are completed
before or after business hours.

Perform a backup prior to
upgrade

Ensure that a successful backup is taken immediately prior to the upgrade
occurring and that no users log in again until the server has been upgraded

Upgrade the server before
any workstations

Terminal Server sites - ensure that all users are logged off the server prior
to starting upgrade

Laptops – ensure that all laptops that have downloaded data are returned to
the practice and synchronised with the server data before upgrading the
server

Test the upgrade Ensure that the upgrade is tested and considered successful before
workstation upgrades are started or the centre opens for business.

Upgrade all workstations Clients that are not upgraded to the new version will be unable to access
the management module.

STEP 3: AFTER YOU UPGRADE

ü Item Further Information

Update your Medicare
Online configuraiton, if your
practice requires multiple
Minor IDs.

See Setting up Online Claiming for multiple locations on the facing page for
instructions on supporting multiple Minor IDs.

Note: This is not mandatory and you may wish to complete this at a later
stage.

John Murtaugh's patient
documentation

John Murtagh's patient education leaflets are now available from patient
education resources.

Recall appointments Practice nurses can now cancel Recall appointments.

Reports Payment reports, transaction reports, and the Reversed Payment report
now include details on bounced cheques.
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Setting up Online Claiming for multiple locations

Important: If you are using another Management package that uses Online Claiming, you
will need to finalise and receipt all claims in that package before configuring Bp Premier for
Online Claiming. Medicare Online Claiming can only operate from one software package at
a time.

If you have installed Bp Premier Lava Service Pack 1, you can set up Medicare Online claiming if your
practice has more than one physical location, and uses multipleMinor IDs.

Follow the instructions in this section if any of the following apply:

your practice had several Minor IDs registered with your previous PracticeManagement Soft-
ware, and you want to keep using them
your practice is adding a new location that will have a separateMinor ID and certificate.

If your practice has multiple locations, but you only use oneMinor ID for Medicare online claiming, fol-
low the instructions for Setting up Online Claiming for single location.

For more information about registering multipleMinor IDs and possible impacts on PIP payments,
refer to the Department of Human Serviceswebsite.

If you have set up Medicare Online previously at your practice, you may already have completed steps
1 (Obtain Minor ID) and 2 (Register with Medicare).

CAN I INSTALL MULTIPLE NASH CERTIFICATES?

From Lava Service Pack 1, sites will be able to register and claim against multipleMinor IDs in the soft-
ware. Each Minor ID will require a matching Medicare Site certificate to enableMedicare online claim-
ing.

However, the NASH certificate (or eHealth Record Site Certificate), which is the certificate used to
identify the practice to My Health Record online, is independent of theMinor ID. Your practice does
not need to install multiple NASH certificates based on the number ofMinor IDs registered in the soft-
ware.

You only need to update your NASH certificate if your practice changes the HPI-O number (Setup >
Practice Details > Change >Health Identifier) or the certificate is about to expire.

NASH certificates and practice incentives

There is no incentive benefit to a practice for installing more than one NASH certificate. A NASH cer-
tificate applies only to accessing My Health Record online and securemessaging. NASH certificates
have no effect on howMedicare calculates Standardised Whole Patient Equivalent (SWPE) values for a
practice.

For more information on practice incentives, refer to the Department of Human Serviceswebsite.

IF YOUCHANGED TO BP FROMANOTHER BILLING PACKAGE

If you recently changed from another billing package, your practicemay not have the latest Medicare
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Online components for Bp Premier installed. Check the following:

1. From themain menu, click Help > About and check that the Build No. shows '1.8.6.759' or higher
and the Version shows 'Lava Service Pack 1'.

2. In Windows File Explorer, browse to the C:\ drive of the Bp Premier server and look for the folder
C:\Program Data\BPOnline.

If the folder does not exist, theMedicare components have not been installed during the install-
ation of Bp. To apply these components, close down the Bp Premier server and reapply the pro-
gram upgrade for your version of Bp Premier. When you reach theOnline Claiming installation
screen, tick Install the Best Practice Software Online Claiming module.

3. Browse again to the folder C:\Program Data\BPOnline. If the folder still does not exist, contact
Best Practice Software Support for assistance.

1. OBTAIN YOURMINOR ID

TheMinor ID is an 8 digit number derived from your Best Practice Software Site ID.

1. Identify your Site ID. Select Help > About from themain Bp Premier screen. Your Site ID is dis-
played in the bottom left of the screen.

2. Take your BP Site ID and prefix it with the letters BPS.
3. Pad the ID with zeroes so that the total length is 8 characters.

For example, if your Best Practice Software Site ID is '849', your MedicareMinor ID number would be
'BPS00849'.

If your practice uses multiple Site IDs, you will have a Minor ID for each Site ID.

If you are adding a new location to your existing Bp Premier installation that will require a newMinor
ID and Medicare Site Certificate, contact the Best Practice Software Relationship team on 1300 401 111.

2. REGISTERWITH MEDICARE

You must register and obtain a Medicare Site certificate for each practice location.

If you are already registered but are using another management package, you can use your cur-
rent site certificates to set up Medicare Online in Bp Premier, but you will still need to notify Medi-
care to tell them you are now using Bp Premier. You will have to supply all Minor IDs.
If you are not currently registered, you will need to register and apply for a Medicare Site Cer-
tificate. You will have to supply all Minor IDs.
Each time you add a new doctor to a location, you will have to notify Medicare to add this doctor.

The Practice Details Form for online claiming and Payee Provider Banking Details Form can be found
in the list ofMedicare forms at:

http://www.humanservices.gov.au/health-professionals/forms/

3. ENABLE ONLINE CLAIMING

If you have obtained a current Medicare Site certificate and Minor ID for each of your practice
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locations, you are ready to set up Medicare Online claiming in Bp Premier.

I have already set up Medicare Online claiming for one practice location

If you have already configured Bp Premier for one practice location, and just need to add the site cer-
tificates for new practice locations, select Setup > Configuration > Online Claiming from themain
screen and tick theMultiple Medicare Locations checkbox. Go to 4. Import site certificates on
page 32.

This is the first time I am setting up Online Claiming for Bp Premier

1. Log in to the Bp Premier server as a user with administrator permissions.
2. Select Setup > Configuration from themain screen. Select theOnline claiming tab.

3. Complete the fields in this screen, using the table below for guidance.

Field Description

Activate
Online Bulk
Bill Claiming

Tick to activate online claiming for bulk billing, if your practice offers bulk billing and wishes to
process bulk billing claims through Medicare online claiming.
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Field Description

Activate
Online Private
Patient
Claiming

Tick to activate online claiming for private patients, if you wish to process patient claims through
Medicare online claiming.

Activate Tyro
Integrated
EFTPOS

Tick this option if your practice uses a Tyro terminal and you wish to process online claims
through the Tyro terminal. See Configuring Tyro for more information.

Activate
EasyClaim
Private Patient
Claiming

Tick this option if you wish to process Easyclaim payments through the Tyro terminal. See
Configuring Tyro for more information.

Always send
private patient
claims by best
available
method

Tick if you intend to use the Online Patient Claiming for private billings and wish to default for all
private claims to be sent to Medicare.

Minor ID If you are setting up Medicare Online claiming for multiple locations, leave this field empty.

Multiple
Medicare
Locations

Tick this checkbox.
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Field Description

Proxy details If you are unsure whether your practice's network uses a proxy server, contact your IT system
administrator for advice

When the Medicare components are installed, the installer automatically creates the
environment variables EASY_API_LOG, EASY_PARM1, EASY_PARM2, and HICOL_LIB_PATH. If
your site uses a proxy server, you will need to create two additional environment variables within
Windows on each Bp workstation that will process Medicare online claims.

These variables are:

EASY_PARM3 — name of the proxy server

EASY_PARM4 — port for the proxy server.

If your practice's Bp machines use system variables, add the two environment variables on each
workstation. If your practice's Bp machines use user variables, add the two environment
variables for each Windows user on each workstation.

If you are unsure how to add environment variables in Windows, contact your IT support or Best
Practice Software Support.

Medicare Online will need to communicate through your proxy server to access the Medicare
servers. Depending upon your proxy server, you may need to allow traffic to and from the
Medicare Australia URL: https://www2.medicareaustralia.gov.au/pext.

If your proxy server also requires a 'User name' and 'Password', enter the Proxy ID and Proxy
password.

A5 Vouchers Tick to print Medicare and DVA vouchers as two separate A5 pages. If not selected, the two
copies will print side by side on a single A4 page.

Print 2 copies
of vouchers

Tick if you wish to print two copies of each Medicare assignment form.

Maximum No
of vouchers in
a batch

Defaults to 80. This is the recommended maximum batch size, but can be reduced. Best Practice
Software do not recommend that you increase this value.

Default
number of
months to
display when
viewing all
batches

Sets the default number of months to display when viewing batches from the Direct Bill Batches
screen.

Default
payment
method for
Online Patient
Claiming

Defaults to EFT or Cheque when processing online claims.
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Field Description

Path to
Certificate
Store

The certificate store is created on the Bp Premier server and shared by all workstations where
transmission to Medicare is to occur. This path is where Bp will store the certificates after they
are imported using the Import Medicare Certificate and Import site certificates buttons.

DO NOT copy your Medicare certificates manually into this folder. Certificates must be imported
using the buttons. Do not change this folder from C:\ProgramData\BPOnline\.

4. Click Change to display the Path to Certificate Store screen. Click Save. Bp will prompt that the
certificate store does not exist and ask ‘Would you like to create one now?'

5. Click Yes to create the store. You will be prompted for a passphrase for the certificate store.

Note: Do not misplace this password. You are responsible for this password; Best Practice
Software cannot retrieve this for you.

6. Click Import Medicare certificate to import theMedicare Australia public key. TheHeSA Cer-
tificates screen will appear, showing the currently installed certificates.

7. Click Change folder. Navigate to the folder C:\Program Files\Best Practice Soft-
ware\BPS\MedicareCerts and click OK.

8. Select a certificate labelled 'Medicare Australia...' and click Attach. If the certificate is imported suc-
cessfully, Bp Premier will display 'The certificate was successfully imported'.

9. Repeat step 8 for each certificate labelled with 'Medicare Australia'.
10. Click Close to close theHeSA Certificates screen. Keep the Configuration screen open.

4. IMPORT SITE CERTIFICATES

If you tickedMultiple Medicare Locations, the Import Site Certificates button will be disabled. You
must import Medicare Site certificates using Medicare's PKI certificatemanager.

1. Install the PKI certificatemanager on the Bp Premier server.

Go to theDepartment of Human Services PKI page and click the link at the bottom of the page
to install the PKI Certificate Manager Installer software.

2. Run the PKI CertificateManager. The Store Setup Wizardwill appear.
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3. Select Use an Existing Store and click Next.
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4. Click ... and browse to the file C:\ProgramData\BPOnline\hic.psi. Click Open, and click Finish on
the Store Setup Wizard. The PKI Certificate Manager screen will appear.
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If you have previously configured Bp Premier for Medicare Online, two certificates will already be
listed in the Personal tab. These certificates apply to the location you had specified as the primary
location for your practice. If you have not set up Medicare Online before, the Personal tab will be
empty.

5. Click Import.... The Certificate Import Wizardwill appear.
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6. Enter the passphrase for the certificate store, supplied to you by Medicare. The passphrase is the
same password set for the certificate store when first setting up Medicare Online. Click Next.
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7. Click ... and browse to the folder containing the site certificate for the location you want to add.
Select the file fac_encrypt.p12 and click Open. Click Next.
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8. Enter the PIC password for the location's site certificate. Click Next. The certificate will be dis-
played ready for import.
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9. Click Finish to import the fac_encrypt.p12 certificate into the PKI Certificate Manager screen.
10. Repeat steps 5—9, but select the file fac_sign.p12. Both certificates should be imported into the

PKI Certificate Manager screen.
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11. Repeat steps 5—10 for each practice location you want to configureMedicare Online for. You will
need to import the fac_encrypt.p12 and fac_sign.p12 files for each location.

12. Record the value in the Email column for each certificate pair shown in the PKI Certificate Man-
ager screen. You will need to enter associated email addresses in 5. Assign certificates to prac-
tice locations below.

13. Close the PKI CertificateManager.

5. ASSIGN CERTIFICATES TO PRACTICE LOCATIONS

To handle online claiming, Bp Premier must knowwhich certificates are associated with which practice
locations.
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1. Select Setup > Practice Details. The Practice Details screen will open.

2. Select the first location in the Practice Locations list and click Edit. The Location Details screen will
appear.

Lava Service Pack 1 Upgrade Guide Page 41



3. Enter theMinor ID for the location.
4. Enter theMedicare Certificate E-mail for the location. The associated email for a certificate can

be found in the PKI CertificateManager.
5. Click Save.
6. Repeat steps 2—5 for each practice location.

6. TEST THE LINK TOMEDICAREON THE SERVER

Before sending your first batch, Best Practice Software recommend that you test the link to Medicare
for each location.

1. Log in to the Bp Premier server and select the first Location from the Login screen. Click Login to
continue logging in.

2. From themain screen of Bp Premier, select View > Patients. The Patient list screen will appear.
Enter a surname or part to Search for.

3. Select a patient name and click View details. The Edit patient screen will appear.
4. ClickMedicare / DVA eligibility check at the bottom of the screen. This will contact Medicare

and check whether theMedicare No. is valid for this patient. If the communication is working cor-
rectly, Bp Premier will display a message similar to the one below.

Page 42 Lava Service Pack 1 Upgrade Guide



5. If the test is successful, exit the Edit patient screen and perform the test from step 1 for each prac-
tice location.

If the test is not successful, contact Best Practice Software Support to diagnose the problem.

7. CONFIGURE ALL WORKSTATIONS
I have already set up Medicare Online claiming for one practice location

If you have already configured Bp Premier for online claiming, and just added site certificates for new
practice locations, perform 6. Test the link to Medicare on the server on the previous page on each
workstation to test connectivity to Medicare.

If each location connects to Medicare on each workstation, setup is complete.

This is the first time I am setting up Online Claiming for Bp Premier

1. Exit from Bp Premier on the server.
2. Browse to the folder C:\ProgramData\BPOnline on the server and share the folder across the net-

work.
3. Give all Windows users who access Bp Premier ‘full control’ permissions to the folder and its con-

tents.
4. Browse to the file HIC.psi, right-click and select Properties > Security tab. Ensure that all users

have ‘full control’ permission to this file.

Note: Your practice's IT support can help if you are unsure how to share folders and change
access permissions.

5. Go to the first workstation.
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From themain menu, click Help > About and check that the Build No. shows '1.8.6.759' or higher
and the Version shows 'Lava Service Pack 1'. Check the folder C:\ProgramData\BPOnline exists on
that workstation.

If this folder is not found on the workstation, reapply the program upgrade for the version of Bp
Premier on this workstation. When you reach theOnline Claiming installation screen, tick Install
the Best Practice Software Online Claiming module.

6. Log in to Bp Premier on the workstation.
7. Select Setup > Configuration from themain screen. Select theOnline claiming tab.
8. Tick Activate Online Bulk Bill Claiming, Activate Online Private Patient Claiming, or both,

depending on the online claiming services your practice offers.
9. Set the Location Name to your practice's Main Surgery and the Location code for your practice is

correct.
10. Beside Path to certificate store, click Change and either type in the UNC path to the certificate

store on the server (for example, '\\servername\BPOnline') or browse to this folder and click
Save.

11. Click Check certificate expiry. If sharing has been set up correctly for the certificate store, Bp
Premier will display the certificates and their expiry dates.

12. Follow the steps outlined in 6. Test the link to Medicare on the server on page 42 to confirm
that the workstation can communicate to Medicare.

13. Repeat steps 5—12 on all workstations on the network.

Best Practice Software recommend that you create an online batch with just a few transactions and
transmit this as a test. If the text batch is successful, you can create larger batches for transmission.
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Downloading Bp Premier Lava SP1 update from the website

Tip: . To check the program and drug database version you are currently using, log in to Bp
Premier on each machine and select Help > About from the main screen.

DOWNLOAD THE PROGRAMUPDATE
1. Log on to the computer as a Windows user with Administrator Rights.
2. Open your internet browser and enter the addresswww.bpsoftware.net. You will be directed to

the Best Practice Software home page.

3. Click on theUpdates > Program update heading. You will be directed to the Bp Program Update
page showing the link to the Lava Service Pack 1 - 1.8.6.801 edition of Bp Premier.

4. Read this page carefully to ensure that you have performed all the required preparations and
have the required prerequisites to perform the program update.

Lava Service Pack 1 Upgrade Guide Page 45

http://www.bpsoftware.net/


5. Once you have performed the preparations, complete the user details at the bottom of the
screen. Type in your BPS Site ID and your email address and click the Login button. The button
will change to Download.

6. Click theDownload button to commence the download. The download process will differ slightly
according to the internet browser you are using. Follow the instructions for your browser below.

Note: The upgrade file will be called BP_1.8.6.801.exe. The example screenshots belowmay show
a different version number.

MICROSOFT INTERNET EXPLORER

A dialog box will appear (similar to the example shown) and you will be prompted to either Run or
Save.

DO NOT SELECT RUN as this will attempt to run the update over the internet.

Press the Save button to save the update utility.

In newer operating systems, the file will be downloaded to your downloads folder. If you want to
save the file to a different folder, press the arrow to the right of the Save button, select Save as,
and browse to the folder you wish to save it in.
In older operating systems, the browser will download to the last folder used. If you want to save
the file to a different folder, press the Save button and browse to the folder you wish to save it in.

Once downloaded, a dialog box will appear confirming the filename and that the download has com-
pleted.

To run the update immediately, and you have read all the documentation on applying the pro-
gram update, press the Run button.
To run later, press theOpen folder button and take a note of which folder the file has been saved
in, so you can come back to it later.

GOOGLE CHROME

A dialog box will appear towards the bottom of the screen and you will see the progress of the file
being downloaded.
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Once downloaded, the progress display will disappear and the icon will change colour.

To run the update immediately, and you have read all the documentation on applying the pro-
gram update, left-click on the down arrow to the right of the dialog box and select Open.
To run later, select Show in folder and take a note of which folder the file has been saved in, so
you can come back to it later.

MOZILLA FIREFOX

A dialog box will appear to show the file to be downloaded.

Press the Save file button. The download will commence.

While the file is downloading, an arrowwill appear in the right-hand corner. When finished, the arrow
will disappear. The downloaded file will be found in your downloads folder. Either browse to this folder
and run the update or return and run the update at a later time.

TO RUN THE UPDATE AT A LATER STAGE

If you have not opted to run the update immediately, when you are ready to run the update, find the
downloaded file in the folder you identified above and double-click on the file.

The file will be called BP_1.8.6.801.exe. If you have downloaded previous program updates, make sure
you select the correct file for the version you wish to upgrade to.

SeeUpgrading from the Lava Service Pack 1 installation DVD on the next page for instructions on
installing the Bp Premier Lava SP1 update.
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Upgrading from the Lava Service Pack 1 installation DVD
These instructions provide the information required to upgrade your existing version of Best Practice
to Bp PremierLava Service Pack 1 (SP1) using the Lava SP1 installation DVD.

Tip: To check the program and drug database version you are currently using, log into Bp
Premier on each machine and select Help > About from the main screen.

BEFORE YOU START THE UPDATE

Important: Ensure that you are logged on to each computer you are upgrading as the
Administrator.

Back up the database and successfully test a restore from the backup before upgrading.

SERVER: Program updates often change database tables used by the program. While this is being
done, performance could be affected on all workstations on the network. Best Practice software there-
fore recommends updating the server outside of business hours or when the server is not under load.
A server update would usually take between 20 – 60minutes to apply.

TERMINAL SERVER: If your practice runs Bp Premier on a terminal server, log ALL users out of Bp
Premier before starting the update.

WORKSTATION: After applying successfully to the server, the upgrade can be applied to each work-
station. The update should only take a fewminutes. While upgrading workstations, Bp Premier can be
used on other computers on the network. Performance should not be affected.

LAPTOPS: Ensure that all laptops which use the Remote database function have synchronised their
data to the server before upgrading the server. Upgrade the laptop workstation afterwards.

If you are not sure about any of the above items, contact your IT support technician for advice and
assistance.

Important: Ensure that you have your system meets the Operating System and SQL data-
base versions supported as described in the Bp Premier Lava System Requirements.

RUN THE PROGRAMUPDATE FROM THE DVD

Your practice name and program version will be different to the example screenshots provided below.
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Upgrade the Bp Premier Server first, then all
workstations

Log on to the computer as the Administrator.

Insert the DVD. The installer should begin
automatically. If not, select Start > Run and
type X:\setup, where X is your DVD drive letter.

The Best Practice Prerequisites screen will
appear. Confirm that you have the prerequisites
required.

Check that the version at the bottom of the
screen reflects the new version.

Click Next.

Select the Express installation and click Install.

The installer will detect that you have a current
version of Best Practice and prompt you to
Update.

Click OK to continue.
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The Bp Premier Program Files screenwill
appear showing the version to be installed.

Ensure that this is the intended version and
click Next.

The Best Practice Software End User Licence
Agreement will be displayed. This has recently
been changed, so please ensure that you have
read this document carefully.

If you agree with the terms and conditions,
select I agree and click Next.

If you do not agree with the terms and
conditions, select I Disagree and cancel to exit
the update process.

The update will automatically detect a 'Server'
or 'Client' installation and select the correct
radio button.

Do not change this setting.

You do not need to change the Destination
Folder. The Bp Premier update will
automatically set this for you.

Click Next.
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The next screen displayed will be the Online
Claiming installation option.

Tick this box if you wish to use Medicare Online
on this machine and you do not currently use
Medicare Online from another application (such
as another practice management software).

Click on the FAQ button to view details on
setting up Medicare Online.

Click Next.

The Bp Premier update will back up your
program files as a precautionary measure in
the event you need to roll back to the existing
version.

The installation will begin.

If upgrading the server:

At the end of the program update, the Update
Database function will run to update and check
the database structure.

When Update Database is complete, if the drug
database is older than the one bundled in the
program update, the Live update function will
run to update the drug database.

This entire process will take some time,
depending on the database size and server
resources.

Important: If your practice uses HealthLink and you have not already upgraded to Bp Premier Lava, the installer
will open port 8080 in Windows firewall on the server machine as part of HealthLink configuration. Please make
your IT technician aware of this so that any necessary actions can be performed.
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When the update is complete, the Completed
successfully screen will be displayed.

The checkbox at the bottom will install or
upgrade some 3rd party software. This includes
MediSecure, Argus, and HealthLink.

If you do not want to install or upgrade any
of these 3rd party products, untick the check-
box and click Finish. The upgrade will com-
plete.

To install or update any of these 3rd party
products, tick the checkbox and click Finish
to display the 3rd Party Providers screen.

Tick the checkboxes to install or upgrade the
listed 3rd party products. Click Next. The
installer will install or upgrade the components.

Refer to the following documents or search in
the Bp Premier online Knowledge Base for
information on how to install / use these
applications:

Installing Argus

Configuring MediSecure

Accessing HealthLink Online forms

Accessing Healthshare fact sheets.

If a current version of MediSecure ePrescribing
software is already detected on the server and
is an older version, the Medisecure checkbox
will be ticked automatically.
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When the installation of the 3rd party products
is complete, the Finish screen will appear.

Click Finish to close the screen and exit the
upgrade utility.
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