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Setting up the Clinical module for the first time
After you have installed Bp Premier for the first time, or converted from an existing clinical software
package, you must apply some basic configuration to start using Bp Premier. The following provides an
overview on how to set up the components of the Clinical module. Before you begin: 

enter a valid Bp Premier licence key into the server. If you do not have a licence key, contact Gen-
eral Products Support on 1300 401 111.
log in to Bp Premier on the server and each workstation to confirm the connection to the Bp
Premier server.

Complete each section in sequence.

UPDATE THE PROGRAMANDDRUGDATABASE VERSION

Check that you have the latest drug database version installed.

To check, select Help > About. The About Bp Premier screen will appear.

Program Version

The installed program version is shown in bold at the top of the screen. Check this against the program
update section on our website www.bpsoftware.net. If any newer program versions available, you
may want to upgrade your current Bp Premier installation.
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If you are upgrading to Bp Premier Lava Edition or later, significant changes to the software have been
made that will affect your practice's workflows. You must review the Lava release notes and upgrade
checklist before upgrading to the Lava edition. The following documents are available from the Bp
Premier Knowledge Base:

Bp Premier Lava Release Notes
Bp Premier Upgrade Checklist - Lava
Upgrading to Lava from the DVD.

Drug Database Version

The last drug database version is shown in the Last drug update field. Check this date against the data
update section of our website www.bpsoftware.net and if any newer data updates are available, down-
load them in chronological order and install to the server only. SeeUpdating the drug database in the
Bp Premier Knowledge Base for more information.

Following an update

After each update, select Help > About again to ensure that the updated version is now shown.

ENTER PRACTICE DETAILS

If you have converted your data into Bp Premier from another package, the practice details will con-
tain the same information as the old system.

If you are starting from an empty database, you are prompted to enter the practice details when you
first log in to Bp Premier.

Note: Ensure your practice details are correct. Bp Premier uses the practice information entered
when printing items like scripts, invoices, and receipts.

There is only ever one practice name in the software. However, you can createmultiple practice loc-
ations to be printed on scripts, invoices, and reports. Users select a location when the user logs in to
the software.

To add practice details:

1. Select Setup > Practice from the Bp Premier screen. The Practice details screen will appear, show-
ing:

practice name
a summary of howmany licenced users you have
the licence expiry date
each practice locations that are set up
contact details for the first location on file.

2. Click Change. The Practice details update screen will appear.

Page 4 Clinical Setup Guide

http://kb.bpsoftware.net/


3. Update any details and click Save.

Theremust be at least one location record. Most practices will have only the one practice location.
However, you can createmultiple practice locations. Location details are printed on scripts, invoices,
and reports.

To add a location:

1. Select Setup > Practice from the Bp Premier screen. The Practice details screen will appear.
2. Click Add next to the Practice Locations list field. The Location details screen appears.
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3. Complete the details for this location and click Save.

The Rural / Remote area checkbox controls which Medicare incentive is added to bulk-billed
invoices for pensioners, health care card recipients, and children. If unticked, incentive '10990' is
used; if ticked, '10991' is used.

LSP Number is the Location Specific Practice Number used when practices provide diagnostic ima-
ging services or radiation oncology services.

The Exempt from Diagnostic Imaging rules checkbox is used in remote areas where Diagnostic
Imaging Services are provided and the practice is exempt from the claiming rules.

To delete a location:

1. Select the location on the Practice details screen and click Delete. A prompt will appear if any
users have provider numbers linked to that location.

2. If the location is deleted, users with linked provider numbers will still be visible, but the provider
number linked to that location will no longer be visible.

To restore a deleted location:

1. Select the Show Deleted checkbox at the bottom of the screen to view deleted locations.
2. Select the deleted location in the Practice locations list field and click Restore.
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SET UP THE SYSTEM FORUSE
Link to a third party billing package

If you are using a third party billing package, you will need to configure the link options with Bp
Premier. If your practice also uses Bp Premier's billing module, you do not need to perform this step.

Open Bp Premier on the server and configure the link options to your billing package:
Linking Bp Premier to Pracsoft
Linking to E-Claims
Linking to a third party billing package.

Information on linking to billing packages can be found in the Bp Premier Knowledge Base.

Test the linking is working between the two applications:

1. Add a new patient in the billing package and ensure that the patient transfers into Bp Premier.
This will take up to oneminute to transfer.

2. Change an existing patient demographic in the billing package (make a minor change, such as
from 'St' to 'Street') and ensure the demographic is updated in Bp Premier. This will take up to
oneminute to transfer.

Set up results and secure messaging import

1. Set up Results Import options for importing pathology and radiology results as described in Set-
ting up results importing on page 16.

2. Configure Pathology and Radiology forms as described in Setting up radiology forms on page 13
and Setting up pathology request forms on page 10.

3. Set upMessaging Providers for securemessaging and electronic referrals (if required at your prac-
tice).

4. Run the BpLink program under Start >Program files > Best Practice Software > Best Practice >
BPLink.

BpLink must run continuously on the Bp Premier server. The BpLink program checks periodically
for results and patient demographic changes waiting to be processed, and also runs any con-
figured scheduled backups. When run the first time, a bird icon will appear in the system tray. See
Configuring Bp Link in the Bp Premier Knowledge Base for more information.

Note: Terminal Server sessions will not run or display the BPLink.exe file. You must run BpLink
from the Bp Premier server to enable automatic linking to billing, pathology import, and Bp
Premier scheduled backups to occur.

Review User settings

1. Check user permissions for all users to ensure they have appropriate access.
2. Give one trusted user full permissions and store the password for this user in a fireproof safe for

emergency access.
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3. Log each user into their workstation to:
Configure their preferences — Setup > Preferences
Configure their printers — Setup > Configuration > Printers
Update their password — Setup >Users.

Update standard lists

Bp Premier provides a a number of standard lists that can bemodified to suit your practice.

1.  Go to Setup > Configuration > Lists.
2.  Add and modify list items for the following lists:

Reason for ceasing medication
Contact category
Document type
Appointment type
Reason for cancelled appointment

3. If you have duplicate items in your list (common items with slightly different spelling, for example)
use the Clean up button to merge duplicate items.

4. From the Configuration screen, select the Reminders tab.
5. Best Practice Software recommends that the checkboxAllow free text reminders be unticked.

Disallowing this option forces providers to select a reminder reason from the preconfigured list.
6. Add any reminder reasons applicable to your practice.
7. Select the Care Plans tab. Add any Care plan goals and Care plan tasks applicable to your prac-

tice.
8. Click Save to save your configuration changes.

Configure Bp Premier Email (optional)

If the practice intends to use the inbuilt email functionality, configure these settings via the Setup
> Configuration > Email screen.

Bp Premier email allows you to compose email messages from the internal word processor, and send
and receive emails from individual user email addresses and a practice-wide email address.

Configure Bp Premier Messages

If the practice intend to use the inbuilt message functionality, add message groups and message users
by selecting Setup > Configuration > Messages.

Bp Premier messages allow internal messages to be sent and received between Bp Premier users. Mes-
sages are unrelated to the secure messaging services used for electronic referrals.

Enter patient demographics

If the practice did not convert from another clinical package, you will need to input your patient demo-
graphic information by selecting File > Open Patient > Add new.
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Add Contacts

Contacts are individuals, companies, or institutions of relevance to the practice. Contact details are
stored in the database.

If the practice converted from another clinical package, the contact list will be populated with the data
from the other system. If the practice did not convert from another package, you will need to add third
party contacts by selecting View > Contacts > Add New.

Configure Bulk Document Import

Bp Premier provides a Bulk Document Import utility for bulk scanning or importing documents. Con-
figure this utility for each user who will be importing documents. See Importing clinical documents in
bulk in the Bp Premier Knowledge Base for more information.
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Setting up pathology request forms
By default, Bp Premier uses a standard format for pathology forms and very little needs to be changed
in order for them to print. However, because some laboratories use pre-printed stationery and others
do not, before you can print pathology forms, you must:

1. Add the pathology provider as a contact.
2. Create a request layout for the pathology provider.

You can set the default preferred pathology provider for a doctor. When a doctor creates a pathology
request from the patient record, the preferred laboratory will be preselected.

CREATE A PATHOLOGY REQUEST LAYOUT
1. Select Setup > Preferences > Pathology from themain Bp Premier screen. TheUser preferences

screen will be displayed for pathology.
2. In the Laboratory Details section at the bottom right, select the laboratory that you want to set

up the layout for and click Edit. This will display the Laboratory code screen.

3. Complete the fields in this screen:

Field Description

Laboratory code Enter a code if the laboratory requires a code printed on the request.

Preferred laboratory Tick this box if this laboratory is the user’s preferred laboratory. When the user
creates a pathology request from the patient record, the request will default to this
pathology lab.

Use plain paper Tick this box if the laboratory does not provide pre-printed stationery.
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Field Description

Paper has specimen labels Tick this box if the pre-printed stationery has a section for specimen labels.

When this box is ticked, the Move duplicate section down andMove labels down
fields become available. Enter a measurement in mm to adjust the position from
the top left that the duplicate and label sections are printed.

4. Click Save. Pathology requests can now be printed for this laboratory.

PRINTINGA PATHOLOGY FORM

When printing a request from the patient’s record, the Pathology request screen appears.

Plain Paper Form

If there is no laboratory selected from the Laboratory drop-down list, the request will print on plain
paper.
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Pre-printed Form

If there is a laboratory selected from the Laboratory drop down list, the request will print so that you
can use pre-printed paper according to the lab's layout settings.
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Setting up radiology forms
Unlike pathology forms, there is no standard radiology request form.

For each radiology provider used by your practice, you must:

1. Add the radiology provider as a contact
2. Create a radiology request layout for the provider.

You can set the default preferred radiology provider for a doctor. When a doctor creates a radiology
request from the patient record, the provider and request layout will default to the Preferred Imaging
Provider set in the provider's preferences.

CREATE A RADIOLOGY PROVIDERCONTACT
1. Select View > Contacts from themain Bp Premier screen.
2. Click Add new and the Contact details screen will be displayed.

3. Select Company/Institution at the top.
4. Select a Category of 'Imaging Provider'.
5. Complete the remaining details for the radiology provider. If the provider can accept referrals in

the CDA format, tick Accepts CDA referrals when adding an address.
6. Click Save.
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CREATE A RADIOLOGY REQUEST LAYOUT
1. Select Setup > Preferences > Imaging from themain Bp Premier screen.
2. Select the radiology provider that you wish to set up the layout for and click Change to display

the Request layouts screen.

3. Any radiology layouts will appear as well as the default ‘Plain paper’ layout.
4. If the lab requires you to use preprinted stationery and it is not already listed, you will need to cre-

ate a layout that suits their stationery. Click Add. The Layout details screen will appear.
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5. Enter themeasurements in mm from the top left corner of the page for each element. Click Save.
6. The new layout namewill now appear in the Request layouts screen. Select the new layout name

and press Save to update the radiology provider to use this layout.
7. Check that the Radiology provider now shows the new layout name under the Format column.
8. You can assign the new layout to any other radiology providers you create.
9. In the Preferred Imaging Provider drop-down list, select the default radiology provider for the

logged-in user. The imaging provider selected here will be automatically selected when the user
creates a radiology referral from the patient record.

10. Click Save & Close to close theUser preferences screen.

Clinical Setup Guide Page 15



Setting up results importing
Bp Premier is able to import pathology and radiology results and electronic documents received
through third party messaging providers. The practicemay usemore than one third party provider for
this purpose.

Before you can set up Bp Premier to import results, you need to:

1. configure Bp Link on the Bp Premier server. See Configuring Bp Link in the Bp Premier Know-
ledge Base for more information.

2. configure the third party software to download results and reports regularly. You will need to con-
sult your messaging software's documentation.

Results are imported to a folder on the Bp Premier server, or another machine in the network you
nominate. Best Practice Software recommends that you set up a separate folder on the server for
these files to be downloaded to (for example, 'c:\Results'). While not necessary, we also recommend
that you have a separate subfolder for each pathology and radiology provider your practice receives
results from. Separate folders can make it easier to diagnose download problems .

However, somemessaging providers require specific paths, and we recommend that you liaise with
themessaging provider' support to assist you with the settings required.

Perform the following procedure on the server or workstation you will use to receive incoming results.
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SETTINGUP RESULTS IMPORTING
Enable results import

1. Select Setup > Configuration from themain Bp Premier screen and select the Results Import tab.

2. Set the following fields:

Field Description

Import investigation
reports on this
computer

Tick this checkbox. This would usually be the Bp Premier server only.

Note: Don't set up two computers to import results. Results import may conflict
between the two machines.
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Field Description

Don't allow
unallocated reports
into Inbox

Tick if you do not want to forward results that have not been allocated to a patient to a
provider's inbox.

If ticked, someone in the practice should be allocated the task of checking for
unallocated results on a daily basis from the View > Incoming reports screen.

Add header to
incoming letters

Referrals and other letters received electronically usually have a patient's name and
address and the top and don't need to show the header visible on results.

Tick if you want to see the results header as well as the address shown on the letter.

Set default storage locations

3. Click the Set storage locations button. The Report Location screen will be displayed.

4. By default, each result type stores in Correspondence In. You can change the store location to
Investigations.

5. If you need to add a new report location for your practice (for example, a unique type of referral),
click Add from the Report Location screen. Type the Report name and select a default store loc-
ation from the Store in field. Click Save to return to the Report location screen.

The Report namewill bematched against the content of the report and identified accordingly.
When processing reports from the provider Inbox, the Inbox indicates where the report will be
saved in the patient’s file: Correspondence In or Investigations.

6. Click Close to return to the Configuration screen.
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Add download paths

7. Click Add next to the Report file search paths. A file explorer will open.
8. Browse to and select the folder to download the report. Click Ok.
9. Repeat steps 7–8 for each path where results are being downloaded to.
10. Complete the rest of the fields in the Results Import tab:

Field Description

Keep HL7 and PIT files
after import

Only tick this box if advised to do so by General Products Support to diagnose an
issue with importing reports.

Report file extensions Most labs will use the standard extension for their results file. However, additional
file extensions can be added here if required for a lab.

Acknowledgements Some labs require that an acknowledgement is sent back to the lab to confirm that
the result has been received. Refer to Setting up results acknowledgement on
page 21.

Number of months to
display in Investigation
reports list

Defaults to 1 month, but you can extend the default month range.

Number of months to
display in Inbox follow up
list

Defaults to 12 months, but you can extend the default month range.

Enable polling for
insurance reports (UHG)

medEbridge is a UHG proprietary system that communicates between Bp Premier
and UHG to electronically complete insurance reports.

Tick this checkbox to enable UHG functionality and enter the login password. See
Using medEbridge in the Bp Premier Knowledge Base for more information.

Include BDI documents in
the Incoming reports list

Tick this checkbox to view documents that are scanned or imported via the Bulk
Document Import utility (BDI ) in the Incoming reports screen.

11. Click Save to save your results import configuration.

HOWRESULTS ARE IMPORTED

There are two ways of importing results into Bp Premier:

1. Run the utility called BPLink on the server. This utility will check every fiveminutes to see if there
are any results and reports in any of the folders indicated in the Report file search paths and if
found will import them into Bp Premier.

Using Bp Link is the preferred method, because Bp Link does not require any user intervention.
See Configuring Bp Link in the Bp Premier Knowledge Base for more information.

2. Select View > Incoming Reports from themain Bp Premier screen. This will force an import of any
results and reports found in any of the folders indicated in the Report file search paths.
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Matching patients and users to results

If the system can match the result to a patient and a doctor the results will appear automatically
in the Doctor’s Inbox. Refer to the help screen on the ‘Inbox’ function for further details on using
this function.
If results cannot bematched to a patient and/or doctor they will remain in the View > Incoming
screen and will need to bematched manually. Refer to the help screen on Incoming Reports for
further details.
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Setting up results acknowledgement
Many securemessaging providers provide a tracking mechanism to confirm that a result, report, or
document has been received by the intended recipient. This tracking mechanism uses an acknow-
ledgement request.

Enabling acknowledgement of results receipt

1. Select Setup > Configuration > Results import from themain Bp Premier screen.
2. Next to the Acknowledgements list, click Add. The Send acknowledgements screen will appear.

3. Enter the Facility name. This needs to be exactly the name stored in the file by the sending facil-
ity.

4. Enter the Acknowledgement path. This is the folder in which the acknowledgement files will be
saved and from which the lab or sending facility can collect the acknowledgements.

5. Click Save to update this setting in the system.
6. Click Cancel to cancel any changes and return to the Results import screen.

After a HL7 result has been imported intoBp Premier, the system will check if the facility name in the file
corresponds with the name listed on the Sent acknowledgements screen. If Bp Premier finds a match,
an acknowledgement file will be created in the path indicated.

There are two types of acknowledgement files:

acknowledgements related to results have the file extension ‘.ACK’
acknowledgements related to reports and referrals have the file extension ‘.RRI’.
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Setting up a messaging provider
Messaging providers are third party companies that securely transmit results, reports and documents
to and from GP practices, specialists, hospitals, pathology and radiology labs. Third party companies
provide and install their own application on your practice server; Bp Premier interacts with that soft-
ware to import or send the document or file.

Before you begin, check with each of your messaging providers to identify the folder they download
documents to (Incoming) and retrieve documents from (Outgoing). Write the folder locations down;
you will need to select the folders when setting up messaging.

Follow the procedures below on the Bp Premier server for each messaging provider that you will be
using.

SHARE THEOUTGOINGMESSAGE FOLDER

Share the folder and set the permissions on the outgoing message folder, so that all users on your net-
work can create documents. Contact your practice's IT support if you are not familiar sharing folder
permissions on Windows.

1. Browse to the folder, right-click and select Properties > Sharing.
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2. On XP and Server 2003, click on Permissions, select the user group 'Everyone' and set Full Con-
trol to allowed.

On Vista or Server 2008 and above, click on Advanced Sharing, tick Share this folder, click on Per-
missions, select the user group Everyone and set Full Control to allowed.

3. Click OK to close the Properties screen.

SET UP YOURMESSAGINGPROVIDERDETAILS

You will need to create a separate record for each messaging provider that you are using. Perform the
following steps on the Bp Premier server only.

1. From themain Bp Premier screen, select Setup > Configuration >Messaging tab.
2. Click Add and theMessaging provider screen will appear.

3. Complete the fields in the screen.

Field Description

Provider
Name

Name of the messaging provider
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Field Description

Path for
incoming
messages

Location for the incoming messages. This can be either the local path or the UNC path.

Path for
outgoing
messages

Location for the outgoing messages. The outgoing path must be different to the incoming
messages path.

Note: The path for outgoing messages must be the UNC path for the folder, so that users on
workstations can access this folder across the network. An example of a UNC path is
'\\server\messagingprovider\out'.

Use the same
path for all
computers

Tick this field so that this setting applies to all users.

Account ID Account ID for this messaging provider (if applicable).

Send CDA
eReferrals

Tick if your messaging provider has the functionality to transmit CDA format eReferrals. The
messaging provider's user documentation or support will be able to tell you if CDA is supported.

Use as default
messaging
provider

Tick if this is your primary messaging provider. The messaging provider will be used if the
contact you are sending a document to cannot accept eReferrals or does not have a preferred
messaging provider.

4. Click Save to save themessaging provider. You can now select this provider when creating a
pathology lab or imaging provider contact.

CONFIGURINGCONTACTS

You need to configure each contact your practice will be sending messages to.

1. Select View > Contacts from themain Bp Premier screen. Select the contact and click Edit to dis-
play the Contact details screen.
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2. In theMessaging provider drop-down list, select the contact's preferred messaging provider.
3. Enter the contact's Account ID for that messaging provider and the contact's Email address.
4. If you know that this messaging provider's software can receive eReferrals in CDA format, select

the contact's address and click Edit, or Add to add an address. Tick the boxAccepts CDA eRe-
ferrals and click Save to update the record.

5. Click Save.
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